Support » Plugin: Really Simple SSL » Error after update

  • Resolved bonannee


    Hi there,

    After the most recent update I received an error, and couldn’t get to the backend of my website anymore. I deleted the plugin and everything works again. Just wanted to let you know.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Contributor Mark Wolters



    thank you for letting us know. Did you happen to see an error message when accessing the backend of your site? For a short while there was a bug in version 3.2 that could cause this, we have now pushed 3.2.1 to fix this. Can you try if using version 3.2.1 also results in the backend becoming inaccessible?

    David S


    @markwolters I noticed everything in the back-end blinking out after updating actually to 3.2.1 and received this error message that took the entire page.

    Is this a security issue we should be concerned with? Can you please update what’s going on?

    Here is a screenshot:

    I get this error when trying to update products or disable certain plugins. I have 3.2.1 and have it disable currently til this is resolved. Is this an issue on our end or the plug ins?

    Fatal error: Uncaught Error: Call to undefined function get_blog_option() in /home/timb8550/public_html/wp-content/plugins/really-simple-ssl/class-multisite.php:667 Stack trace: #0 /home/timb8550/public_html/wp-includes/class-wp-hook.php(286): rsssl_multisite->check_site_protocol(‘https://thecast…’, ”, NULL, ‘/’) #1 /home/timb8550/public_html/wp-includes/plugin.php(208): WP_Hook->apply_filters(‘https://thecast…’, Array) #2 /home/timb8550/public_html/wp-includes/link-template.php(3126): apply_filters(‘home_url’, ‘https://thecast…’, ”, NULL, ‘/’) #3 /home/timb8550/public_html/wp-content/plugins/sg-cachepress/core/Supercacher/Supercacher.php(161): get_home_url(‘/’) #4 /home/timb8550/public_html/wp-content/plugins/sg-cachepress/core/Supercacher/Supercacher_Posts.php(128): SiteGround_Optimizer\Supercacher\Supercacher->purge_index_cache() #5 /home/timb8550/public_html/wp-includes/class-wp-hook.php(288): SiteGround_Optimizer\Supercacher\Supercacher_Posts->purge_all_post_cache(42739) #6 /home/timb8550/public_html/wp-inclu in /home/timb8550/public_html/wp-content/plugins/really-simple-ssl/class-multisite.php on line 667
    The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

    Plugin Author RogierLankhorst


    Hi @affordablewebsitesdenvercom,

    The error I see in your dashboard looks more like the zip file wasn’t download correctly, can you refresh and try again?

    @thecastlejewelry, I have one other report of this error. Are you running on multisite? The function that is failing is a core wordpress function, used in multisite setups, so not sure why it’s failing. If you can contact me directly at, we can communicate directly about this so we can get to the bottom of this issue.

    Plugin Author RogierLankhorst


    Thanks @thecastlejewelry for your input on this. Although extensively tested we missed this possible issue, where a multisite function was loaded on single site installs. This is now fixed in 3.2.2.

    Sorry for the inconvenience caused.

    Plugin Author RogierLankhorst


    @affordablewebsitesdenvercom Can you update to version 3.2.2 and check if that resolves the issue?

    If not, can you contact me at so we can find out what the problem is on your site?

    I can confirm this error still exists in V3.2.2. I’m getting an error page immediately upon activating the plugin for all wp-admin pages for the website for one of my clients.

    The error page simply says “Not Available” I’ll have to either contact the host to get the plugin disabled from their end or delete the plugin via ftp to regain access to the WordPress admin panel. This plugin is mission critical for my client’s site that’s having this issue as SSL breaks the site’s external stylesheets otherwise.

    EDIT: Deleting the plugin’s files does not fix this issue. I still can’t access wp-admin even after deleting really simple ssl via ftp.

    Plugin Author RogierLankhorst


    @radiantfreedom, I have trouble reproducing the issue. Can you contact me at and if possible provide me with FTP and wp credentials? I am looking for a setup where this the issue can be debugged.

    Plugin Author RogierLankhorst


    @radiantfreedom or do you maybe have an error log that could show what the issue is?

    I have updated the 3.2.2 version on about 30 websites without issues, so it must be some specific setup or configuration that I missed. I’m looking for this configuration so I can find the cause.

    If you need a quick fix for the site, you can roll back to 3.1.5 with this link:

    Just checked the error logs, none relevant to this issue.

    Plugin Author RogierLankhorst


    @radiantfreedom possibly the issue you’re experiencing is not related to Really Simple SSL.

    Especially the fact that removing Really Simple SSL does not fix your problem suggests this plugin is not the cause.

    Can you send me the details so I can check what the problem is?

    @rogierlankhorst – I’ll have to get back to this in a bit, looks like a support tech from Bluehost is currently doing some troubeshooting on the site and I’ll need to wait until the plugins are all restored to their original state before I can do anything else.

    The issue is definitely Really Simple SSL. The problem only surfaces when the plugin is active. I suspect the reason deleting it did not fix the issue when I used FTP was that parts of the plugin where left behind due to a non-standard deletion, and those parts caused the error to persist. Reinstalling it and then activating and disabling it normally via a backend that bypassed the regular wp-admin panel available through Bluehost fixed it.

    This plugin being the cause is also confirmed by Bluehost Tier 2 tech support.

    Plugin Author RogierLankhorst


    Is there any indication what the issue was? The problem is, I can’t reproduce it on any site I manage, and I currently don’t have any users with issues in the support inbox.

    It appears to be something tied to your setup specifically, which makes it very hard for me to debug.

    I’ll need to reactivate the plugins which are currently all disabled. Then I can create an admin account for you to use to troubleshoot. I’ll contact you through your site shortly.

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.