Support » Plugin: Popup Maker - Popup Forms, Opt-ins & More » Error after update

  • Resolved pandraka

    (@pandraka)


    I updated PoPup maker this morning and now my site is throwing this error only in the dashboard

    Warning: fopen(/home/navalw5/public_html/test/wp-content/plugins/popup-maker-buddypress-integration/popup-maker-buddypress-integration.php): failed to open stream: No such file or directory in /home/navalw5/public_html/test/wp-includes/functions.php on line 5462

    Warning: fread() expects parameter 1 to be resource, boolean given in /home/navalw5/public_html/test/wp-includes/functions.php on line 5465

    Warning: fclose() expects parameter 1 to be resource, boolean given in /home/navalw5/public_html/test/wp-includes/functions.php on line 5468

    Any ideas on how to fix this asap would be helpful

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author danieliser

    (@danieliser)

    @pandraka – Sorry to hear that. Looking into it now.

    Plugin Author danieliser

    (@danieliser)

    @pandraka Think I worked out a solution, though I don’t think that should occur when using get_plugin_data. I may have to submit a patch for WP core to prevent errors in the case a plugin file doesn’t exist, surprised such a use case has never come up before.

    If you can modify the plugin files yourself and are comfortable doing so, try patching

    wp-content/plugins/popup-maker/classes/Utils/Alerts.php:255-258

    Replace those 3 lines with:

    
    				$path        = "{$integration['slug']}/{$integration['slug']}.php";
    				$plugin_data = file_exists( WP_PLUGIN_DIR . '/' . $path ) ? get_plugin_data( WP_PLUGIN_DIR . '/' . $path, false, false ) : false;
    
    				$installed = $plugin_data && ! empty( $plugin_data['Name'] ) && $plugin_data['Name'] === $integration['name'];
    

    Will put out a patch today for this in just a bit.

    Hope that helps. If your issue is resolved please take a moment to rate and review the plugin or support.

    If you still need help please message us directly at https://wppopupmaker.com/support/.

    Thank you for the quick response. I updated the plugin today and no more error. Thanks again for the quick response and fix.

    Sincerely

    Patricia

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error after update’ is closed to new replies.