Support » Plugin: Booster for WooCommerce » Error after todays update

  • Resolved uffesgjutformar

    (@uffesgjutformar)


    I get this error when installing todays update:

    Parse error: syntax error, unexpected ‘=’, expecting ‘)’ in /***/***/***/***/***/wp-content/plugins/woocommerce-jetpack/includes/class-wcj-product-tabs.php on line 133

    I have removed the url in the message with ***

    4.1.0 works fine (glad I had a backup) but 4.2.0 is crap.

    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi,

    Could you tell me what versions of Woocommerce and PHP are you using, as well as you’re using WPML plugin?

    It crashed my site too and I had to remove the plugin then reinstall it but when trying to activate it this error is thrown

    Parse error: syntax error, unexpected ‘=’, expecting ‘)’ in /home/lv/public_html/wp/wp-content/plugins/woocommerce-jetpack/includes/class-wcj-product-tabs.php on line 133

    php ver 5.4.45
    woocommerce ver 3.5.4

    Thread Starter uffesgjutformar

    (@uffesgjutformar)

    I have the exact same versions as iconMatrix mention.

    Hi,

    Could you try updating to PHP version 5.5 or above?

    I updated PHP to 7.2.15 and the plugin is now activated

    What is the fix for this error? I cannot access the admin of my site (or the site itself) for this error. Do I delete Woocommerce in the hosting file manager?

    There are two which updated around the same time in file manager;

    – woocommerce-jetpack
    and
    – jetpack

    Will that at least get me into the site if I delete both or the correct one? Hope someone can help. Many thanks

    • This reply was modified 3 years, 3 months ago by ash19leigh.

    I would delete woocommerce-jetpack. It requires php 5.5 and above.

    • This reply was modified 3 years, 3 months ago by iconMatrix.

    Hi,

    You should try navigating to /wp-content/plugins directory in your FTP client and renaming Booster plugins to anything else so that you could login to WordPress. Once that’s done try updating PHP version.

    Hello, I’ve tried all PHP versions from 5.5 to 7.2.14 without success. Booster won’t be activated. šŸ™

    WP version is 4.9.5
    WC version is 3.3.5

    EDIT:
    FIXED. the issue disappeared without trying any other change. Maybe it was a matter of time for the server to take php version changes

    • This reply was modified 3 years, 1 month ago by bipolab.
    • This reply was modified 3 years, 1 month ago by bipolab.
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error after todays update’ is closed to new replies.