WordPress.org

Support

Support » Themes and Templates » Error after theme activation

Error after theme activation

  • Tried activating a new theme on my wordpress and this message appears “Fatal error: Call to undefined function wp_get_theme() in /home/hojifo5/public_html/ny4actorsbook.us/wp-content/themes/cakifo/library/functions/utility.php on line 119” and I can’t access my admin area.
    Help, please!!!

Viewing 12 replies - 1 through 12 (of 12 total)
  • Try renaming the theme directory using an FTP program, or file manager if it’s a home server. Then you may be able to get into your admin panel. If that works you can then delete the theme.

    Okay. I’m not that great with tech talk guys. Tried to upload a theme, went to activate it and got this message:
    Fatal error: Cannot redeclare my_init() (previously declared in /home/myname/public_html/mysite.com/wp-content/plugins/pixopoint-menu/index.php:33) in /home/myname/public_html/mysite.com/wp-content/themes/OptimizePress1.45/functions.php on line 340

    Now I cannot access anything.

    How can I fix this…remembering i’m not that techie 🙂
    I am with hostgator if that helps.

    Thankyou!

    Your theme was stored in wp-content/themes/cakifo, where cakifo was the name of your theme.

    By renaming the theme directory to something like :
    wp-content/themes/test_cakifo you should be able to get to the admin panel, select a new theme and get your site back. Do you have the default wordpress themes in your theme directory (ie twentyeleven, and twentyten)? You could pick one of the default themes to get the site back and running.

    I’m not sure what you are doing but it looks like you uploaded a new theme? Do you know about file structures and such?

    One final thought….If you are not comfortable with any of this, find someone you trust that knows wordpress to help you.

    Hi Kevinhaig

    Thanks for quick response. Yes I tried to upload a new theme. I have both those themes however am unable to access them due to getting that message I printed above.

    How do I (or where) do I access the theme directory?
    My admin is showing but each time I click a button I get those messages.

    File structures? No. 🙁

    Looks like you are using the defunct PixoPoint Menu plugin which presumably has a function name identical to one in your theme or elsewhere in your WordPress install. Deactivating the PixoPoint Menu plugin should fix that problem.

    Thanks Ryan

    Problem is I cannot access it because i keep getting that error message.

    Any ideas how to access?

    Okay. Ive accessed Hostgator and am now at File Manager and pixopoint menu

    Am I getting closer to what i need to do here?

    Is this a matter of pressing ‘uninstall’ for this?

    Or am i way off the mark?

    $10 to a paypal account to anyone who can successfully direct me to get this fixed as it is something I need to fix ASAP.

    Thanks

    Hey guys really appreciate some help with this if someone is around.

    Thanks

    Hello Hoji,

    I’m the author of Cakifo. Do you use the latest version of WordPress? The wp_get_theme() function was introduced in WordPress 3.4 and Cakifo is not compatible with earlier versions. You should follow kevinhaig’s instructions and rename the theme folder. After that you should update to the latest version of WordPress and try to active the theme again.

    @fip
    I think it’s better if you create a new thread. But try to delete the ‘pixopoint-menu’ folder.

    Hi, I love Cakifo, and I’m using it with 3.4.2. Because I’ll have users using my (not yet publicly announced) app with 3.3, I want to have myself a 3.3 Website with Cakifo. Is there an old version of Cakifo I can download?

    Answering myself 😉 Version 1.3 at https://github.com/jayj/Cakifo/tags seems to work nicely with 3.3 — easy to remember: 1.3 for 3.3 and 1.4 for 3.4 😉

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Error after theme activation’ is closed to new replies.