Support » Plugin: Comments - wpDiscuz » Error after submitting comment

  • Hi,

    I am able to hit the submit button but then the page keeps showing the loading graphic and doesn’t display the comment. A red box shows up but I can’t see any text in it. Screenshot link: http://bailbondsnetwork.com/wp-content/uploads/2017/09/error.png

    After refreshing the page, it displays the post so it technically works but it’s a bad experience.

    When I look inside the red box element it shows me this:

    <div class=”wpdiscuz-comment-message wc_invalid_field” style=”display: block;”></div>

    What could be causing this? I don’t have JetPack Comments. I have GZip Compression plugin enabled but don’t know how to clear the cache if that’s the issue.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Checking in to see if someone knows?

    FYI – I’m not using any cache plugins, only gzip compression via my htaccess file.

    Can someone please test and see if they have the same issue leaving a comment, what could be the fix?

    @fcbadi, I’m getting a similar error to yours.

    It has all the symptoms you described with one difference: mine actually shows an error message in the red box that says this below

    SyntaxError: JSON.parse: unexpected character at line 1 column 2 of the JSON data

    Plugin Author gVectors Team

    (@gvectors-team)

    Thank you for letting us know, we’re currently checking this error…

    Thank you for looking into this. Please note that I am on WordPress version 3.9.20 and using WPDiscuz version 4.0.14.

    Plugin Author gVectors Team

    (@gvectors-team)

    I’m sorry but it’s hard to support WordPress 3.9. Please install a fresh latest WordPress in some sub-directory and test wpDiscuz. If it works then it’s version compatibility issue.

    Totally understand, was really hoping to use it since I can’t upgrade this website to 4.0+. Is there any way to see if you can spot something? Could you point me to another version for 3.9x that could work?

    The plugin notes state it’s compatible with WordPress 3.8.0 so I’m assuming this should work… I think it would be great to look into still.

    Plugin Author gVectors Team

    (@gvectors-team)

    We know that, I think this is not just a WP version issue, this is something complex. Other plugins versions, jQuery version, server PHP/MySQL version. I think all is old because of WP core old version. You can install a fresh WP 3.9 and test it with wpDiscuz.

    I have the same error for users who are not ‘admin’ level…
    my site is fully up to date and still in construction

    admins can leave comments but subscribers etc the error:
    SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

    tried updating jquery – no luck

    any suggestions very welcome!

    thanks for great plug!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Error after submitting comment’ is closed to new replies.