Viewing 15 replies - 1 through 15 (of 16 total)
  • Hello @markmemayank,

    I would be more than happy to assist if I can.

    • Is this a new install or an existing one that you converted to network/multi site?
    • What selection under permalinks do you have?
    • What hosting provider are you using?
    • Did you manually install WordPress or did you use your Hosting provider’s one-click install?
    Thread Starter Mayank Kumar

    (@markmemayank)

    This was an existing one.

    For permalink I opt: post-name

    20i is my hosting provider

    Installation is provided by hosting provider means it’s one click install.

    I am using subdomains with my network install. To get this to work correctly I had to add a redirect for the subdomain url to the root directory of my wp site. For example test.mydomain.com redirected to mydomain.com. Try adding a redirect like this mydomain.com/subsite to mydomain.com

    Thread Starter Mayank Kumar

    (@markmemayank)

    Can you tell me like which method I should use to setup this redirect?

    If you have cPanel access to your site. You can create a redirect under the Domains section “Redirects”. You can choose “permanent” and “wildcard” when creating the redirect. If you installed wp in the root of public_html the the redirect URL should be https://mydomain.com/ where “mydomain” is your domain name.

    Please let me know if this resolved your subfolder site not loading the dashboard.

    Thread Starter Mayank Kumar

    (@markmemayank)

    I have created the redirect, still instead of getting open my new site with https://jnvsprep.com/trial it’s redirecting to me at https://jnvstprep.com

    Here multisite override.

    Still the issue is not solved.

    • This reply was modified 8 months, 2 weeks ago by Mayank Kumar.

    When you select “My Sites” and then hover over the site in question and select “Dashboard” What happens?

    Thread Starter Mayank Kumar

    (@markmemayank)

    It’s get redirected to my main domain.

    https://jnvstprep.com/

    Remove that redirect that we created earlier and try again and let me know what happens. Also, what is your site URL when you go to Network/Admin/Sites and edit the site?

    • This reply was modified 8 months, 2 weeks ago by joecoyle.
    Thread Starter Mayank Kumar

    (@markmemayank)

    I just remove the redirect and now we are the same step as we were. Still getting the same error message as in the start.

    Answer for your second question is: https://jnvstprep.com/wp-admin/network/site-info.php?id=3

    This is the URL when I edit the site: https://jnvstprep.com/trial/

    Lets try deleting your.htaccess file so WordPress create a new.

    Connect to your server via ftp cPanel File Manager:

    1. Download the existing .htaccess file to your local computer so that you have a backup.
    2. Once you’ve backed up that existing .htaccess file, delete the .htaccess file on your server.

    If you can log in after deleting the file, go to Settings → Permalinks and click Save. This forces WordPress to generate a new .htaccess file. You don’t need to change any settings – just click the Save button.

    If you still can’t log in, that means the problem probably wasn’t with your .htaccess file. You can reupload the backup copy

    In the above steps, when it mentions logging back into your site, this would be your main site and not the sub site. You would then go into the permalinks to save.

    The link you provided to show me the site URL for your sub site, I am unable to access. Can you just type the site URL in this post. For example https://mydomain.com/subsite

    • This reply was modified 8 months, 2 weeks ago by joecoyle.

    @markmemayank

    Do you have an update or a chance to try my suggestion above?

    Thread Starter Mayank Kumar

    (@markmemayank)

    Yes, I deleted the htaccess file and update the permalink, but what happening is my htaccess file is not getting generated. And after removing the htaccess file, my multisite sub directory is giving me the Not Found error. I am attaching that screenshot below.

    https://ibb.co/s14qMsX

    Thread Starter Mayank Kumar

    (@markmemayank)

    Hey @joecoyle

    My error has been just solved now.

    I am explaining like how it has been solved.

    I added the recommended htaccess configuration by WordPress to my .htaccess file.

    https://wordpress.org/documentation/article/htaccess/
    I modified the part of my .htaccess file according to this blog.

    I really appreciate your time & efforts for me to reply for this and even following me up.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Error after setting up multisite network’ is closed to new replies.