Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » Error after login I can’t see the dashboard

  • Resolved viframm71

    (@viframm71)


    Salve oggi si è presentato il seguente problema, appena accedo alla dashboard mi da una serie di errori, allego screenshot

    Hi today the following problem occurred, as soon as I access the dashboard it gives me a series of errors I write to you what appears to me:

    /home/wp-content/plugins/give/src/License/PremiumAddonsListManager.php on line 42

    wp-content/plugins/give/src/License/PremiumAddonsListManager.php:42) in /web/htdocs/site address /home/wp-includes/functions.php on line 6362

    /home/wp-content/plugins/give/src/License/PremiumAddonsListManager.php:42) in /web/htdocs/site address/home/wp-admin/includes/misc.php on line 1310

    • This topic was modified 5 months ago by viframm71.
Viewing 5 replies - 1 through 5 (of 5 total)
  • JMSDOnline

    (@jmsdonline)

    Just to echo this, I started receiving the very same error today.
    PHP Warning: Invalid argument supplied for foreach() in /.../wp-content/plugins/give/src/License/PremiumAddonsListManager.php on line 42
    Renaming the plugin to give_BAKUP seems to restore access to the wp-admin, but removes any donation functionality of course. To add to this, no updates or changes have been made in about 3 weeks to the site.. so this is incredibly perplexing.

    • This reply was modified 5 months ago by JMSDOnline.
    Plugin Support Rick Alday

    (@mrdaro)

    Hi there,

    Our team has escalated this issue to the highest priority and will be taking a look at this immediately. Please follow along at this feedback post for the latest: https://feedback.givewp.com/bug-reports/p/warnings-for-add-ons-list-manager

    Thanks for your patience while we work on this issue.

    hvorrath

    (@hvorrath)

    Same error – appears 22 times, then
    “Header information – headers already sent by (output started at /home/customer/www/genesisbaroque.com.au/public_html/wp-content/plugins/give/src/License/PremiumAddonsListManager.php:42) in /home/customer/www/genesisbaroque.com.au/public_html/wp-includes/functions.php on line 6362”
    then
    Warning: Invalid argument supplied for foreach() in /home/customer/www/genesisbaroque.com.au/public_html/wp-content/plugins/give/src/License/PremiumAddonsListManager.php on line 42

    another 22 times.

    Like JMSDOnline, there have been no changes and no significant activity on my website. Could it be that GiveWP has made some change to your licensing which is causing an issue for those of us using the Free version, no add-ons?

    Thread Starter viframm71

    (@viframm71)

    I have applied what D O advised at this link (https://feedback.givewp.com/bug-reports/p/warnings-for-add-ons-list-manager) and it seems to work.

    I await the update of the plugin with correction of the error

    Plugin Contributor Ben Meredith

    (@benmeredithgmailcom)

    Thanks, all. The workaround to comment out the line should definitely work. I am going to mark this post as resolved, because all further discussion will be over on the feedback site. This is our team’s highest priority today.

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.