Support » Plugin: WC Custom Emails Per Product » Error after last update

  • Resolved mari125

    (@mari125)


    Right after updating the plugin after yesterday’s release, I started getting this error throughout the Processing order email.

    Warning: in_array() expects parameter 2 to be array, boolean given in /home/oxycise3/public_html/wp-content/plugins/woo-custom-emails-per-product/includes/class-woo-custom-emails-output.php on line 154

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author alexmustin

    (@alexmustin)

    Hi @mari125,

    Thanks for using my plugin!

    I need more information, please.

    – How many products are in your orders?
    – What type of products are they? (regular Woo product, booking, box office, etc)
    – What is the payment method you used?

    Thread Starter mari125

    (@mari125)

    Thanks for your quick response!

    So far I have only had orders for 1 item – a subscription product. The error has only appeared when they pay with PayPal, not with credit card. I use the WooCommerce PayPal Powered by Braintree Gateway plugin for payments.

    Thank you for your help!

    Hi. Same issue.
    1 product in order. Demo product but woocommerce bookings. Stripe payment method. Many thanks

    Warning: in_array() expects parameter 2 to be array, boolean given in /home/magabibl/public_html/wp-content/plugins/woo-custom-emails-per-product/includes/class-woo-custom-emails-output.php on line 196

    Plugin Author alexmustin

    (@alexmustin)

    Thanks @jlcobb22, I’m aware of the issue.

    A fix should be out soon.

    Thanks for using my plugin!

    I have same issue, too.

    Warning: in_array() expects parameter 2 to be array, boolean given in /home/tgeea328/public_html/wp-content/plugins/woo-custom-emails-per-product/includes/class-woo-custom-emails-output.php on line 154

    Thanks for replying 🙂

    Hi Alex. Is there a workaround in the meantime to stop customers seeing the error messages? e.g can I comment out something on the order confirmation php?

    Plugin Author alexmustin

    (@alexmustin)

    Hi all following!

    @marzelld, @t608183, @jlcobb22, @mari125

    I have just released a fix for this issue — please download version 2.2.2 and let me know if this issue is resolved for you.

    Thanks!

    Your a legend Alex! Working fine now on my end. Many thanks

    Plugin Author alexmustin

    (@alexmustin)

    Great to hear it, @jlcobb22.

    Thanks again for using my plugin!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Error after last update’ is closed to new replies.