Support » Plugin: Acunetix WP Security » Error after install: You do not have sufficient permissions to access this page

  • Resolved wpgeekster


    I installed Acunetix WP Security. Now I can log into my dashboard. Everything in the dashboard works except the WP Security link and all it’s submenus. For each submenu including: Dashboard, Database, Scanner, Live Traffic and all the rest I get an error: You do not have sufficient permissions to access this page.

    I did not change the database table prefixes. I did not run anything in the Acunetix WP Security plugin. I went to my file manager and it looks like all the necessary files have 755 permissions. I did notice that the files in the plugins/wp-security-scan/res/pages folder have 644 permissions, but I would not suspect that to be a problem. Yet I don’t know. I looked at the database and all the tables have the same prefix. There is not .htaccess file in the wp-admin folder. Maybe this is a bug that resulted from the wp 3.6.1 update. Hopefully someone will answer this post. I’d like to get that plugin working. Thanks

Viewing 14 replies - 1 through 14 (of 14 total)
  • So I went into the dashboard of a different site which has the same theme (Roots WordPress Theme my favourite) and updated to 3.6.1. By the way, both of these sites are multisites. When I went to the site, the Acunetix logo and WP Security link was no longer present. So I uninstantiated the Acunetix plugin and reinstalled. Now the Acunetix Logo/link is present, but it does the same thing. It gives an error: You do not have sufficient permissions to access this page. So this time I left the plugin installed because I’m afraid that if I uninstall, it might break something. I hope someone responds to this post and Acunetix fixes the problem. I’m sure that I’m not the only one who will be affected by this.

    Exactly the same here. Multisite subdomain with own folder, 3.6.1.

    The Acunetix broke WordPress.

    I needed erase the Acunetix plugin folder to take WP back.

    Same thing here: network activate and the Acunetix icon and such appears in the sidebar, but selecting any of the sub-items gives a permissions error.

    What happened? Upgrades are supposed to make things better, not break everything.

    Also does anyone know why they now have 2 plugins that look similar:
    This one: and another:

    Has anyone tried that 2nd one on Multisite? Why are they being so confusing?

    Plugin Author Acunetix



    We are very sorry to hear about these issues, but nor this plugin or Secure WordPress are multisite ready. We are looking into the possibility of providing support for multisite, but in a future version.


    The old version worked just fine with Multisite. Also why is there 2 plugins (linked to above) now? Which should we be using?

    Yes, the old version worked fine in Multisite. Can’t you look at the code you changed in this latest version and see why it broke? It doesn’t seem like it should be hard to figure out what happened. I think it should be a priority to make it multisite ready. Secondly is that it is generating a permissions issue. The permissions most likely have to do with database access. You should be easily able to correct that issue, or tell us how to correct it in our websites so that we can make the changes. @tevya, I like the way this plugin scans the file permissions. A very simple basic check, but fundamental to security. I’m going to check that other plugin you posted and see if it scans.

    Plugin Author Acunetix


    Hello, wpgeekster

    Thank you for your feedback. We are already looking into this issue (and the others that have been reported) and trying to find a solution for this.

    The thing is that there are a few things that need to be modified in the case of a multisite so we scheduled this for a future version (this feature needs a lot of testing too).

    The reason these two plugins are similar is because we have dropped the support for the websitedefender scanner from them and we are focusing now mainly on this plugin.


    You say you’ve dropped support for the website defender scanner. Does that mean that the plugins will no longer be able to scan my public_html directory and report the permissions. That’s one of the best features of your plugin and basically so far the only reason I use your plugin. It wouldn’t make sense to remove that functionality. On the other hand, I may be misinterpreting what you are saying. So please let me know if the file permissions scanning capability is going to be removed.

    Also, is there a place where the previous version can be downloaded from?


    @ wpgeekster

    You can download previous version at :

    When you have downloaded the previous version, then in the Dashboard, go to Plugins / Add, and click on Send (after Search, in the Install page). Click on Browse button to indicate the path of plugin archive. Click on Install now button.

    Good luck.


    @ Acunetix

    Could you say if the above method to return to a previous version is correct? The database is updated it when the update 4.0.1 plugin is applied?

    I have the same problem, on a multisite installation in WP 3.6.1, I get an error: You do not have sufficient permissions to access this page for every link of the WP Security Scan menu.



    Plugin Author Acunetix


    Hello guys,

    It seems that since we released the 4.0.1 version some of you have experienced weird behavior of the plugin. We are very sorry for this but please understand that without seeing some of the log files it is very hard for us to see what happens on your backend.

    Rest assured we are trying to find a way to fix all these issues and version 4.0.2 will clear them all away.

    One important issue is that most of you are trying to install this on a multisite instance of WordPress, but version 4.0.1 doesn’t support multisite

    Another issue is the settings page. in v4.0.1 we have made all settings configurable, in comparison to the previous versions, and we have used the PHP’s ReflectionClass, but seems that some hosts do not have support for this, so we have updated the plugin to offer an alternative for that special case.

    As you can see, we are trying to fix all issues that you report, and also we intend to offer support for Multisite starting with version 4.0.2.

    @wpgeekster: We dropped the support for the WebsiteDefender service, not the internal directory scan.

    @tevya: yes, that is correct.

    Costin (plugin dev team)

    Might be advisable to put a Big Warning on the plugin front page in the repository to warn people off while you fix this. Multisite is built-in, now. If you’re not going to support Multisite (make that “remove support for Multisite”) tell people, so they’re not freaking out that they’ve been hacked; when it’s a security plugin that’s causing the issue!

    Sounds good Acunetix

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Error after install: You do not have sufficient permissions to access this page’ is closed to new replies.