Support » Fixing WordPress » Error After 5.3 Update

  • bobsled

    (@bobsled)


    I’m getting this error after updating. I have tried disabling all plugins one by one but no joy.

    Warning: count(): Parameter must be an array or an object that implements Countable in xxxxx/wp-admin/includes/plugin.php on line 1392

    Any advice?

Viewing 15 replies - 16 through 30 (of 42 total)
  • ispreview

    (@ispreview)

    Just for good measure I put a bug report in:

    https://core.trac.wordpress.org/ticket/48599

    Target fix for 5.3.1.

    bobsled

    (@bobsled)

    Good move, ispreview.

    hummelmose

    (@hummelmose)

    Nice move @ispreview – I have written my info on the bug as well. I’m running PHP 7.2.19 and NewsMag theme.

    hummelmose

    (@hummelmose)

    And it actually got worse for me now – The media library (and upload of new files) don’t work. Anyone else with same problem?

    bobsled

    (@bobsled)

    I just checked @hummelmose. Yes, I see the same issue. Can’t access images in the media library. But I can access the library from a post edit, but can’t upload images.

    hummelmose

    (@hummelmose)

    Thank’s @bobsled

    So we’re truely f***d

    bobsled

    (@bobsled)

    Yes, it seems like a buggy release @hummelmose. Luckily I have only updated my staging test site. Hopefully there will be a fix update from WP soon.

    hummelmose

    (@hummelmose)

    Lucky I have a server image backup from 1AM last night – So I’m on my backup server now, rolling back on primary.

    Quite a buggy release.

    bobsled

    (@bobsled)

    Good luck with it!

    mephistophales

    (@mephistophales)

    Warning: count(): Parameter must be an array or an object that implements Countable in xxxxx/wp-admin/includes/plugin.php on line 1392

    I have same problem!
    ı just change the plugin.php file with the previous version (wordpress v5.24) and there is no error right now but i’m not sure this way is healty or not but i’m sure there is some errors on plugin.php file… I’ll be waiting for the permanent fix for it.

    PS: My hosting running on PHP v7.3

    @bobsled thank you for the sharing this problem hope we’ll find a way for fix it.

    ivanocarditello

    (@ivanocarditello)

    same problem here, hope there will be a solution soon…

    MartinGrebe

    (@martingrebe)

    I installed the Plugin “Query Monitor” and the Error has gone.

    hummelmose

    (@hummelmose)

    @martingrebe – That was weird.

    I still will wait for the 5.3.1 update.

    Can you check if that plugin also solves the media library issue with no images in library from root menu, and no capabilities to upload new pictures when creating posts.

    ispreview

    (@ispreview)

    If you install and active query monitor then the warning/error still exists, it’s just hiding it on the admin frontend (you’ll see a notice at the top and if you click that it’ll list the warning). Maybe less annoying but not a fix.

    bobsled

    (@bobsled)

    I have had success in removing the error and accessing the media library.

    I thought I had disabled and checked every plugin. But I must have missed one in my first check. After disabling my plugins one by one again, I found that NextScripts: Social Networks Auto-Poster was causing the problem.

    Once I disabled this plugin, all is fine.

    So I can recommend that if you have any problems with 5.3, make sure you disable all plugins and then enable them one by one to find the issue.

Viewing 15 replies - 16 through 30 (of 42 total)
  • The topic ‘Error After 5.3 Update’ is closed to new replies.