Support » Fixing WordPress » Error After 5.3 Update

  • I’m getting this error after updating. I have tried disabling all plugins one by one but no joy.

    Warning: count(): Parameter must be an array or an object that implements Countable in xxxxx/wp-admin/includes/plugin.php on line 1392

    Any advice?

Viewing 15 replies - 1 through 15 (of 42 total)
  • Same Problem here.

    Same here.

    • This reply was modified 3 weeks, 1 day ago by enivid.

    Same here. It’s only an annoying warning though.

    That seems related to menus and this particular ticket https://core.trac.wordpress.org/ticket/39776

    I don’t know a lot about it but I’ll try to see if we can get more information.

    Yes @youknowriad, it seems to be related to sub menus in particular. I have only updated my staging site for the moment. The site’s frontend is working fine. So it’s only an annoying warning in the admin screen. Hopefully I can I can find a fix. But if not, perhaps wait for an update of 5.3.

    Same here. Quite annoying.

    Yes I also get this after upgrading to 5.3, although I noted that it occurs under my PHP7.3 environment but not on my beta one where I’m using the latest PHP7.4 RC.

    Good to know @ispreview. I’m running 7.3. But I’m reluctant to update the PHP on all my sites just for this.

    Nor should you bobsled, PHP7.4 is not yet fully released and some plugins may break with it. Hopefully the WP team can fix this bug instead as it must be hitting a fair few sites on 7.3.

    Thanks ispreview. Yes, I’ll wait for a fix from WP.

    Bonus question: I also get several messages like this one:

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/9/d141745617/htdocs/misc/wp-admin/includes/plugin.php:1392)

    referring to the same line in plugins.php. Are those triggered by the original one and will disappear once the root cause is fixed?

    Yes, marcusraitner. It looks like the same issue to me, related to navigation menus. It’s the same error line as I am getting : plugin.php:1392.

    This is also my assumption @bobsled … just wanted to know if I have to look also for something else.

    I would wait @marcusraitner. Unless someone on this thread has a good idea, I would wait for a WP 5.3.1 update.

    Will do @bobsled. However, such a type mismatch (parameter doesn’t implement Countable) shouldn’t be so hard to find and fix …

Viewing 15 replies - 1 through 15 (of 42 total)
  • You must be logged in to reply to this topic.