Support » Fixing WordPress » error admin-ajax.php 404 customizing tweenty seventeen

  • i just reinstalled a clean version of wordpress. when i want to customize the theme by adding a menu name “social links menu” with custom links to the different sites i cannot save.
    I always get the following error:
    POST http://marcosorrego.com/wp-admin/admin-ajax.php 404 (Not Found)

    i tried disabling all plugins and rolling back 1 modification i did to the functions.php file that i read in the jetpack documentation for using only wordpress.com login function.

    Other than that, i cannot update the theme.

    tried adding to .htaccess
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    but did nothing.

    Also as a note, the file does exist.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must have fixed it, since a request to the URL it is now returning HTTP 200, so the file exists. If you paste the URL in the browser you should see a zero.

    Did you solve your original issue?

    Thread Starter shawtux

    (@shawtux)

    nope, still happening.
    Failed to load resource: the server responded with a status of 404 (Not Found)

    Thread Starter shawtux

    (@shawtux)

    retried with a clean install and no imported posts or configurations and still happens.
    tried removing cloudflare dns and still nothing.

    Thread Starter shawtux

    (@shawtux)

    reset .htaccess to default from instalation and checked vs the wordpress codex

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    still error is maintained.

    I am experiencing the very same issue with the HashOne theme from HashThemes. Cannot save any appearance customizations.

    Actually – just discovered I CAN delete something from the primary menu, but cannot add anything to it.

    Brucy

    (@brucy)

    Ever find a solution to this?

    Thread Starter shawtux

    (@shawtux)

    Changed hosting

    johank1986

    (@johank1986)

    Hello,

    I have also a wordpress admin-ajax.php problem: First my WordPress admin-ajax.php returns 0 and now it’s a clean sheet.

    https://www.voetbalshirtsdirect.nl/wp-admin/admin-ajax.php

    I tried the answers online but still no reaction. Can someone help me please 🙂

    Cheers,

    Johan

    Hello,

    This should be related to your host’s web application firewall. Try contacting them.

    For me, that was the solution. Hope it helps to you too.

    Cheers,
    Ujith

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘error admin-ajax.php 404 customizing tweenty seventeen’ is closed to new replies.