Support » Plugin: Pods - Custom Content Types and Fields » Error adding new PODS CPT (“Please enter a Name for the Pod”)

  • Resolved jjci

    (@jjci)


    Just some minor background: I have already created some PODS custom post types which I am still using, and I have also deleted some which I am no longer using. Previously, I was able to create a new CPT with no problems.

    When trying to create another new PODS Custom Post Type, after clicking the “Next Step” button the label changed to “Processing…” and then I received a popup message reading “Error: Please enter a Name for this Pod”. However, the next form where I would normally have entered the Pod name had not even been displayed.

    After this error occurred, I ran a test to ensure that I was able to create new custom taxonomies, and that seems to be working fine. I also flushed the cache, logged out, and re-started my laptop, but nothing made any difference.

    I am really stuck until I can create new custom post types.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter jjci

    (@jjci)

    An additional note:

    On the first page, the “Advanced +” link is not working, i.e. clicking on it does not change the screen. However, the same link works for a new Taxonomy and for a new Custom Settings Page.

    Thread Starter jjci

    (@jjci)

    Another additional note (which is a workaround to the original problem):

    If I select Custom Post Type, the “Advanced” link does not work therefore I cannot enter a name for the new Pod.

    However, if I select Custom Taxonomy (or Custom Settings) the “Advanced” link opens correctly. At that point I can change my selection to Custom Post Type and the “Advanced” link content remains open allowing me to specify the name for the new pod. The creation of the new pod fields works correctly from that point.

    The same problem occurs if I attempt to create another new POD CPT. However, I can easily employ the workaround described above.

    Plugin Author Jory Hogeveen

    (@keraweb)

    Hi @jjci

    This is a known issue since WP 5.6 and we already have a patch that will be released shortly!
    https://github.com/pods-framework/pods/pull/5893

    Cheers, Jory

    pmarques75

    (@pmarques75)

    It’s happening to me on WordPress 5.3.6.
    When should we expect a fix for this?

    Thank you,
    Pedro

    Plugin Author Jory Hogeveen

    (@keraweb)

    Hi @pmarques75

    The fix was already released..
    Please create a new issue where you fully explain your issue in detail!

    Cheers, Jory

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Error adding new PODS CPT (“Please enter a Name for the Pod”)’ is closed to new replies.