Support » Plugin: IBM Watson Assistant » Error activating watson conversation plugin

  • Resolved rosboc

    (@rosboc)


    I got following error activating plugin by wp cli.
    Command used is:

    wp plugin install <plugin-name> –activate

    default: Scaricando pacchetto di installazione da https://downloads.wordpress.org/plugin/conversation-watson.0.8.9.zip&#8230;
    default: Scompattamento del pacchetto…
    default: Installazione plugin…
    default: Plugin installato correttamente.
    default: Activating ‘conversation-watson’…
    default: WordPress errore sul database You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘json,
    default: p_status enum(“new”, “processing”) DEFAULT “new”,
    default: s_created timestamp DE’ at line 4 per la query CREATE TABLE wp_watsonconv_task_runner_queue(
    default: id integer(64) UNSIGNED NOT NULL AUTO_INCREMENT,
    default: p_callback varchar(256) NOT NULL,
    default: p_data json,
    default: p_status enum(“new”, “processing”) DEFAULT “new”,
    default: s_created timestamp DEFAULT CURRENT_TIMESTAMP,
    default: PRIMARY KEY (id)
    default: )DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci fatta da include(‘phar:///usr/local/bin/wp/php/boot-phar.php’), include(‘phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/wp-cli.php’), WP_CLI\bootstrap, WP_CLI\Bootstrap\LaunchRunner->process, WP_CLI\Runner->start, WP_CLI\Runner->_run_command_and_exit, WP_CLI\Runner->run_command, WP_CLI\Dispatcher\Subcommand->invoke, call_user_func, WP_CLI\Dispatcher\CommandFactory::WP_CLI\Dispatcher\{closure}, call_user_func, Plugin_Command->install, WP_CLI\CommandWithUpgrade->install, Plugin_Command->activate, activate_plugin, include_once(‘/plugins/conversation-watson/watson.php’), require_once(‘/plugins/conversation-watson/includes/background-task-runner.php’), WatsonConv\Background_Task_Runner->__construct, WatsonConv\Background_Task_Runner::check_installation, dbDelta
    default: Plugin ‘conversation-watson’ activated.
    default: Success: Installed 1 of 1 plugins.
    default: ====== configure wordpress aspect
    default: WordPress errore sul database You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘json,
    default: p_status enum(“new”, “processing”) DEFAULT “new”,
    default: s_created timestamp DE’ at line 4 per la query CREATE TABLE wp_watsonconv_task_runner_queue(
    default: id integer(64) UNSIGNED NOT NULL AUTO_INCREMENT,
    default: p_callback varchar(256) NOT NULL,
    default: p_data json,
    default: p_status enum(“new”, “processing”) DEFAULT “new”,
    default: s_created timestamp DEFAULT CURRENT_TIMESTAMP,
    default: PRIMARY KEY (id)
    default: )DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci fatta da include(‘phar:///usr/local/bin/wp/php/boot-phar.php’), include(‘phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/wp-cli.php’), WP_CLI\bootstrap, WP_CLI\Bootstrap\LaunchRunner->process, WP_CLI\Runner->start, WP_CLI\Runner->load_wordpress, require(‘wp-settings.php’), include_once(‘/plugins/conversation-watson/watson.php’), require_once(‘/plugins/conversation-watson/includes/background-task-runner.php’), WatsonConv\Background_Task_Runner->__construct, WatsonConv\Background_Task_Runner::check_installation, dbDelta

    MySqlServer version 5.5
    WordPress version 5.1.1

Viewing 6 replies - 1 through 6 (of 6 total)
  • kaneua

    (@kaneua)

    Hello rosboc.

    Thanks for sharing your error message and software version. Right now plugin has a compatibility issue with older versions of MySQL and MariaDB. The fix for it is developed and dev team now tests it. It will be released at the beginning of the next week. As a temporary workaround you may upgrade your MySQL to version 5.7.8 or higher or MariaDB 10.2.7 or higher.

    If you have any more questions or issues, feel free to share them.

    • This reply was modified 8 months ago by kaneua.
    rosboc

    (@rosboc)

    Hi,
    thanks for the update.
    Unfortunately the latest version available on ubuntu 14.04 is 5.6 and i was not able to find the 5.7.8.
    When new plug-in version will be delivered ?

    Plugin Support intelahelp

    (@intelahelp)

    Hello @rosboc,
    we are going to release 0.8.10 in a couple of hours.
    This version should fix the issue you’ve faced with.
    Thank you for your patince.

    Plugin Support intelahelp

    (@intelahelp)

    Hello @rosboc!

    The plugin was updated to the version 0.8.10. This version includes the fix for your issue. Please update the plugin on your website and let us know if the issue persists.

    rosboc

    (@rosboc)

    It worked.
    Very super support.
    Thanks

    Plugin Support intelahelp

    (@intelahelp)

    You are very welcome

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Error activating watson conversation plugin’ is closed to new replies.