Support » Plugin: WordPress Related Posts » Error activating 2.8 version of Related Posts

  • Resolved xavyxd


    I am getting this error:

    Fatal error: Uncaught exception ‘InvalidArgumentException’ with message ‘Passed variable is not an array or object, using empty array instead’ in /home/xavy/public_html/wp-content/plugins/wordpress-23-related-posts-plugin/config.php:67
    Stack trace:
    #0 /home/xavy/public_html/wp-content/plugins/wordpress-23-related-posts-plugin/config.php(67): ArrayObject->__construct(false) #1 /home/xavy/public_html/wp-content/plugins/wordpress-23-related-posts-plugin/config.php(111): wp_rp_get_options()
    #2 [internal function]: wp_rp_activate_hook(”)
    #3 /home/xavy/public_html/wp-includes/plugin.php(406): call_user_func_array(‘wp_rp_activate_…’, Array)
    #4 /home/xavy/public_html/wp-admin/plugins.php(150): do_action(‘activate_wordpr…’)
    #5 {main} thrown in /home/xavy/public_html/wp-content/plugins/wordpress-23-related-posts-plugin/config.php on line 67

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hey, thanks for reaching out, I’ll do my best trying to help you out!

    Do you have access to your data-base? If so, try to delete field with option_name = wp_rp_options from table wp_options.

    Let me know if this helped in any way or if the problem persists!

    Take care & I’m looking forward to your reply!


    Hi there:
    First of all, sorry for my late reply
    I’m afraid the issue persists. Should deleting wp_rp row in wp_options help with this?

    Perhaps some more information about how this happened, might help. After some issues with my ISP, I have jhad to restore my blog from some backup files and db (db qas pretty recent, files might not be as much)

    I uploaded the files, configured the new sql settings, and restore the db, and had to disables every plugin because I was receiving some errors (db had to be updated) After moving plugins folder to plugins2 (so it was not taken into account by wp) , the blog updated the db, and I was able to move plugins2 to plugins back. After doing this, I could reenable every plugin on my site, except this particular one.

    I would prefer to keep my config, but if not possible I would not mind deleting my plugin config starting from 0, as long as I can enable it πŸ˜‰

    Hey, don’t worry about the late reply, but I think this thread might be of some help to you as well:

    Let me know if deleting this wp_rp_meta entry helped or not. πŸ™‚

    Take care & I’m looking forward to your reply!


    Thanks a lot! That definetely helped. Sorry for not finding it myself in my previous search!

    Hey, don’t worry about it, I’m just glad it worked out for you! πŸ™‚

    As always β€” if you have any questions or if you stumble upon any problems, do not hesitate to let us know! We’ll gladly help!

    Take care & have a nice weekend ahead!


    Hello SIlvo:

    I think I was messing posts….

    Finally this was not solved as I was getting a You’re not allowed to reach this page error, even though I was logged in as the only admin user. I even created a new admin user, with the same results. Could you please tellme which modifications the plugin does in order to be activated? I think I should be able to delete enay row or table this might create and then, this should allow me to configure the plugin from scratch

    Hey @xavyxd, thanks for getting back to me, since this is definitely not something we’d expect to happen!

    And since we are a bit in the dark of what’s going on here, we’d would like to most kindly ask you, if there’s a chance you could grant us the credentials to your WP Dashboard, since we’d really like to find out why this is happening (especially because we simply cannot replicate the same problem on our end).

    Let us know if this is something you are comfortable with or if you have any additional questions what-so-everΒ β€” we’ll do our best to help you out!

    Here’s my email address:

    Take care & have a nice day!


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Error activating 2.8 version of Related Posts’ is closed to new replies.