Support » Plugin: Video Gallery - YouTube Playlist, Channel Gallery by YotuWP » Error: Access Not Configured. YouTube Data API has not been used in project

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author yotuwp

    (@yotuwp)

    Hi @temak
    I think issue related to the API.

    You can try that again after some minutes or create new one API

    Looking forward to hearing from you.

    Best regards,

    Anthony

    Thread Starter temak

    (@temak)

    Hi,

    I have retried for hours but doesn’t seem to work. To be clear, here are the http restrictions I currently have set for the current API key – http://prnt.sc/sb8klt

    Kindly help confirm if these are correct so I know if that’s where the problem lies.

    Kind regards.

    Plugin Author yotuwp

    (@yotuwp)

    Hi @temak

    Please use the IP restriction instead of http.

    Because the gallery request API from the hosting, not from your browse.

    Please follow step #7 in my article https://www.yotuwp.com/how-to-get-youtube-api-key

    Hope that convenient for your plan.

    Best regards,
    Anthony

    Thread Starter temak

    (@temak)

    Hi,

    Thank you for the guide. So i followed it and added the IP address from my cpanel and then tried it again. It gave an error message that the ip wasnt included in the restriction so I added the IP address that it noted – http://prnt.sc/sc0n5y

    The ip error message went away and it just came back to the same initial error – Error: Access Not Configured. YouTube Data API has not been used in project 791959014549 before or it is disabled. Enable it by visiting https://console.developers.google.com/apis/api/youtube.googleapis.com/overview?project=791959014549 then retry. If you enabled this API recently, wait a few minutes for the action to propagate to our systems and retry.

    This problem is getting really frustrating as I am trying to set this up on two different websites and cant seem to get it to work.

    I followed the guide again and tried to create a new api completely but i dont see the create credentials noted in step 5 of your guide. heres what my credentials section looks like – http://prnt.sc/sc0kzv
    so i only have the option to create credentials from the top which you stated “not this one” when trying to create a new credential

    I have created a new api with the specific ip address that the plugin indicated but this too does not work. i just keep getting the access not configured error. I have also cleared the plugin cache and waited for some hours to be sure the api has propagated.

    Please help as i do not know what to do anymore.

    Thread Starter temak

    (@temak)

    Hi,

    Please i am still waiting for your update on this.

    Need this sorted as soon as possible so i can get the two sites running.

    Thanks.

    Plugin Author yotuwp

    (@yotuwp)

    Hi @temak

    For the API, please ensure you enabled the APIs as screenshot https://prnt.sc/se82cq

    If it still does not works, please go to YotuWP Settings > Cache > Turn off

    then try again.

    Looking forward to your reply.

    Best regards,

    Anthony

    Thread Starter temak

    (@temak)

    Hi,

    Thank you for the response. The API is enabled but keeps showing errors. Please check here – http://prnt.sc/seb281 and http://prnt.sc/seb24c

    I have disabled the cache and tried again. This what was I got – http://prnt.sc/seb6jn it keeps saying its not enabled for the project, but it is.

    The site is trying to connect quite alright as can be seen from the dashboard but there’s an error for some reason. Any ideas as to what it might be please?

    Appreciate all the help so far.

    Thread Starter temak

    (@temak)

    Hi,

    I have been able to finally sort it out! I tried with another account and went through the steps and it worked out so all good now!

    Thanks for all the help and support.

    Cheers!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Error: Access Not Configured. YouTube Data API has not been used in project’ is closed to new replies.