Support » Plugin: WP-Stateless - Google Cloud Storage » Error: Access Denied

  • Resolved hichloe

    (@hichloe)


    Hi
    I noticed some of the thumbnails on my site are broken.

    When I inspected the image and checked the url (which is this: https://storage.googleapis.com/stateless-www-xxx-com/2018/01/text-deals-v2.jpg), I get a following error msg:

    his XML file does not appear to have any style information associated with it. The document tree is shown below.
    <Error>
    AccessDenied
    <Message>Access denied.</Message>
    <Details>
    Anonymous caller does not have storage.objects.get access to stateless-www-xxx-com/2018/01/text-deals-v2.jpg.
    </Details>
    </Error>

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Alim

    (@alimuzzamanalim)

    @hichloe Can you make sure that the file exists in Google Storage.

    Ok – just checked.

    No I don’t see the files in the bucket.

    What should I do?

    I just installed the plugin last night and currently have it set – CDN mode. I haven’t synced yet.

    Please let me know what needs to be done.

    My goal is to transfer all files from my local VPS to Google cloud storage (My media files are about 3-4 GB)

    Plugin Author Alim

    (@alimuzzamanalim)

    There could be only one setting that could be responsible for this. File URL Replacement
    It’s replace file url in post content/meta.
    So you can disable this option for now or do the sync.

    Plugin Author Alim

    (@alimuzzamanalim)

    @ideric Maybe we should disable it by default. What do you think?

    I think that’s a good idea, so that there wouldnt be any surprise like what happened to some of the images on my site.

    Thanks for the fast response. I will disable the File URL Replacement setting.

    Plugin Author Eric Sopp

    (@ideric)

    Yep, good idea to keep it off by default. Thanks everyone!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Error: Access Denied’ is closed to new replies.