Support » Plugin: Amazon Associates Link Builder » ERROR: A marketplace is present that has not been set. Please set that first.

  • bengarves

    (@bengarves)


    When configuring the plugin, adding PA-API Credentials, and confirming the Conditions of Use, I receive:

    ERROR: You need to add at least one marketplace entry for tracking ids

    If I add a marketplace entry, the the “Select Marketplace” dropdown is empty, but I can insert my Associates tracking ID. If I do so, I receive:

    ERROR: A marketplace is present that has not been set. Please set that first.

    From what I can find online and in support forums, the common troubleshooting is to:

    • Remove adblocker (I don’t use it)
    • That the first marketplace is a default marketplace and will configure itself after saving the API credentials (It hasn’t)
    • I see notes from over a year ago that this a known bug that would be fixed in the next release, which was a long time ago.

    The page I need help with: [log in to see the link]

  • You must be logged in to reply to this topic.