Support » Fixing WordPress » Error 500 with php 7 o highter

  • Hi,
    I have wordpress installed under php 5.6, but if I want to switch to php 7.1 or 7.2 I get an error 500.
    What is the reason for this?
    Thanks for helping me.

    • This topic was modified 1 year, 9 months ago by Steve Stern.
Viewing 1 replies (of 1 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    WordPress core works with 7.x, so the issue is a plugin or theme.

    Errors like this are logged. Check the error log on your server. If you can’t find the log, please contact your host.

    Meantime, enable wp_debug and wp_debug_log and after an error, look at wp-content/debug.log to see if anything gets logged there. https://codex.wordpress.org/Debugging_in_WordPress

    You can also try this: Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you cannot access wp-admin, there are other ways to deactivate plugins.

Viewing 1 replies (of 1 total)
  • The topic ‘Error 500 with php 7 o highter’ is closed to new replies.