Support » Plugin: WooCommerce Shipping & Tax » Error 500 returned

  • I decided to take the plugin for a test, unfortunately the shipping-rates ajax calls are returning 500 errors each time. I guess I’ll just pass and wait until the plugin becomes more stable.

    {“code”:”wcc_server_error_response”,”message”:”Error: The WooCommerce Services server returned: Internal Server Error An internal server error occurred ( 500 )”,”data”:{“message”:”Error: The WooCommerce Services server returned: Internal Server Error An internal server error occurred ( 500 )”}}

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor danreylop

    (@danreylop)

    Hi Michael,

    We’re sorry your first experience with our plugin was a bad one.

    We got the error recorded on our server. It’s related with the address validation performed by USPS before a shipping label can be purchased. Unfortunately, for privacy reasons, we don’t record the origin and destination addresses that caused the error. If you could give us (by private message if you prefer) the Origin and Destination addresses (screenshots would be fine too) that you used, we can work on fixing that bug.

    Thanks in advance, and we hope you give this another chance soon 🙂

    Plugin Contributor Nabeel

    (@nabsul)

    Hi Michael,

    I’m sorry you had trouble getting set up. We’re looking into this error but are having trouble reproducing it. Would you be willing to help us by providing the following information?

    – What page you were on when the error happened (customer check out, label printing, etc.)
    – Could you provide an address that causes this error? If you don’t want to publicly post the address, you can send me a private message (I use the same handle on twitter).

    Thanks!

    Plugin Contributor Nabeel

    (@nabsul)

    Woops! Duplicate messages, sorry!

    Sorry guys I didn’t keep the plugin on the staging website.
    But the errors were appearing on the label creation, once the addresses were input.
    So yes it’s probably linked to the addresses validations.

    I would like to think even if the addresses were erroneous, we shouldn’t get 500 errors but some more explanatory perhaps. I’m not 100 % sure but I think the same addresses were validated by WC USPS plugins. I didn’t keep track of the addresses.

    Sorry for not being more helpful, I know it’s rather vague.

    We are having the same problem with a client’s site. Same warning:

    Error: The WooCommerce Services server returned: Internal Server Error An internal server error occurred ( 500 )

    Any updated information regarding this?

    I’m also wondering if there’s any solution to this issue yet? I’m getting the 500 error just trying to access the settings once the plugin is installed and haven’t been able to find the cause of the issue.

    we are seeing this too on a site we are about to launch. is there any way to use just the postal part of jetpack without installing the whole thing?

    Plugin Contributor Jeff Stieler

    (@jeffstieler)

    Hello @faberuna, @flightmediachris, @emilysparkle,

    If you’re still experiencing issues with WooCommerce Services, please open Support Threads here: https://wordpress.org/support/plugin/woocommerce-services/ – plugin reviews unfortunately aren’t surfaced as well, and can be missed by our support team.

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Error 500 returned’ is closed to new replies.