Support » Plugin: Ultimate Member - User Profile & Membership Plugin » Error 500 on all pages after WordPress 4.9.6 update

  • Resolved w-sky

    (@w-sky)


    After the latest WordPress update applied today our site became completely unacessible, except for /wp-admin in my logged in session. Using Ultimate Member Version 2.0.13

    All pages, no matter if they should be accessible or redirected showed HTTP error 500

    I think there might be an error in the plugin and deactivated Ultimate Member for now.

    WP debug mode showed this:

    Fatal error: Uncaught Error: Call to undefined function get_home_path() in /webs/booking/wp-admin/includes/misc.php:204 Stack trace: #0 /webs/booking/wp-includes/class-wp-rewrite.php(1775): save_mod_rewrite_rules() #1 /webs/booking/wp-includes/class-wp-hook.php(286): WP_Rewrite->flush_rules(true) #2 /webs/booking/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #3 /webs/booking/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #4 /webs/booking/wp-settings.php(471): do_action(‘wp_loaded’) #5 /webs/booking/wp-config.php(94): require_once(‘/webs/…’) #6 /webs/booking/wp-load.php(37): require_once(‘/webs/…’) #7 /webs/booking/wp-blog-header.php(13): require_once(‘/webs/…’) #8 /webs/booking/index.php(17): require(‘/webs/…’) #9 {main} thrown in /webs/booking/wp-admin/includes/misc.php on line 204

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hi @w-sky, Can you please post a list of all active plugins, and your active theme?

    w-sky

    (@w-sky)

    Sure, these are the active plugins:

    Add-on WooCommerce MailPoet 3
    Advanced Custom Fields Multilingual
    Draw Attention
    Enable Media Replace
    Jetpack von WordPress.com
    Loco Translate
    MailPoet 3 (New)
    Vendidero Helper
    Regenerate Thumbnails
    WC Custom Add to Cart labels
    WooCommerce
    WooCommerce Dynamic Pricing
    WooCommerce Germanized
    WooCommerce Germanized Pro
    Woocommerce Minimum and Maximum Quantity
    WooCommerce Multilingual
    WooCommerce Payment Gateway Based Fees
    WooCommerce Product Add-ons
    WooCommerce Stripe Gateway
    WP Mail SMTP
    WPML CMS Nav
    WPML Media
    WPML Multilingual CMS
    WPML Sticky Links
    WPML String Translation
    WPML Translation Management

    Theme: Deli (child theme for Storefront)

    It seems that the site you mentioned above is now working.

    – Were you able to complete the update?
    – If so, did you change anything in order to get it to complete successfully?

    If you reverted the site and were not able to complete the update, can you try deactivating MailPoet 3 and retrying the 4.9.6 update?

    w-sky

    (@w-sky)

    It was working before now because I had deavtivated Ultimate Member. The updates today went fine without any error messages of any kind, the site is WordPress 4.9.6. I did not revert anything.

    However it is indeed a conflict between MailPoet 3 (Version 3.7.2) and UltimateMember (Version 2.0.13).
    I just found out, if both are active, HTTP error 500 will be the result.

    I have deavtivated MailPoet 3 for now… do you know how to fix this situation?

    And is it MailPoet’s fault maybe?

    Brandon Kraft

    (@kraftbj)

    Happiness Engineer

    It isn’t MailPoet’s fault per se—it is a combination of things related to the 4.9.6 update along with Ultimate Member doing a front-end flushing rewrites request.

    WordPress 4.9.7 will resolve the issue, but in the meantime, you can use MailPoet 3.7.1 (which is the version they’re sending out now to help folks caught by this).

    formerfatguy

    (@formerfatguy)

    Same problem here, but in regards to being able to save and update plugins. All causing 500’s.

    I first became aware of the 500 issue when I tried to simply save a Thrive Architect template page and got a 500 error. Then I tried to update a plugin and got the same.

    all after updating to 4.9.6

    Update: sorry, thought this thread was a general 500 error after updating to 4.9.6. Didn’t realize it was a thread for support on a specific plugin

    • This reply was modified 1 month ago by  formerfatguy. Reason: (adding notify of followups by email)
    • This reply was modified 1 month ago by  formerfatguy.
    Ian Dunn

    (@iandunn)

    @formerfatguy, do you have access to the PHP logs for your site? If so, can you share the relevant entries (likely a “fatal error”). That’ll tell us exactly what the problem is, and if it’s the same problem as the others in this thread. Without that, there’s no way to know.

    It’d also help if you post a list of plugins that are active on your site.

    RowlandA

    (@rowlanda)

    I had the same issue – Error 500 – but only when accessing the Admin side of my site – after updating to WP 4.9.6.

    Disabling Ultimate Member -or- disabling Mailpoet fixed the issue.

    However, my site is running Mailpoet 3.7.2, so apparently that either broke the fix they put in 3.7.1, or there is a new issue / conflict between UM and MP 3.

    The PHP Error is:

    [Sat May 19 11:18:50.406635 2018] [cgi:error] [pid 93167] [client 75.165.178.185:59889] AH01215: PHP Fatal error: Call to undefined function get_home_path() in /<redacted>/wp-admin/includes/misc.php on line 204: /usr/local/cpanel/cgi-sys/ea-php56, referer: <Redacted>/wp-admin/plugins.php?plugin_status=all&paged=1&s

    RowlandA

    (@rowlanda)

    I did some more searching and I found that downgrading Mailpoet to 3.7.1 is the fix – the conflict does indeed come in Mailpoet 3.7.2.

    All better now.

    Hope this helps someone!

    Rowland

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @w-sky and @rowlanda,

    Thanks for letting us know about this issue.
    I’m glad that you’ve found the solution.
    We will investigate this issue on our end.

    Regards.

    Yes Mailpoet had this issue, BUT Ultimate Member was also causing this issue from wp-content/plugins/ultimate-member/includes/core/class-rewrite.php

    Which has add_action( 'init', array( &$this, 'rewrite_rules'), 100000000 );

    
    if ( ! apply_filters( 'um_rewrite_flush_rewrite_rules', UM()->options()->get( 'um_flush_stop' ) ) ) {
        //flush_rewrite_rules( true );
    }
    

    Related CORE ticket: https://core.trac.wordpress.org/ticket/44142

    which is caused by wp-admin/includes/misc.php being loaded via wp_add_privacy_policy_content() when an rewrite flush is requested outside of the admin context

    And because Ultimate Member is flushing rewrites on init is the reason for this problem

    Hi, I’m Josh, the lead developer of Caldera Forms. I left a comment on our Github about this conflict with ultimate member: https://github.com/CalderaWP/Caldera-Forms/issues/2574#issuecomment-394825977 If your dev team has insight on how to work out this conflict with our plugin, let me know there.

    For me it seems this bug is fixed! Currently my site is running fine with MailPoet Version 3.7.6 and UltimateMember Version 2.0.17 on WordPress 4.9.6.

    Both plugins were updated since I have opened this thread. Setting it to “resolved”, all right?

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.