Support » Installation » [Resolved] Error 500 error and cannot edit my Posts (after 2.7 install)

[Resolved] Error 500 error and cannot edit my Posts (after 2.7 install)

  • Hi All,

    I’ve just completed an upgrade from 2.6.5 to 2.7. Most everything works but I can’t see a list of my old posts. I get an Internal 500 Error (please try again later). Also I am still seeing a message – WordPress 2.7 is available! Please update now – even though in the Dashboard it shows that I am running 2.7

    Funny thing, after the install – I didn’t even see anything in the Dashboard (left Pane).

    I did everything according to the install instructions for an upgrade – deleted the old wp-admin and wp-include folders. Then deleted all the php files in the site root and manually created a new wp-config.php. I ran the upgrade.php and everything looked to be ok. However, the site is working but I can’t see my old posts. I can however look at the Pages defined in my site.

    Anyone have a clue what I should try next?


Viewing 11 replies - 1 through 11 (of 11 total)
  • Hello again,

    It seems that no one is monitoring this forum or did every skip over this post! The first problem with the upgrade message is gone – I didn’t do anything.

    However, what mostly concerns me is that I can’t edit any posts. As soon as I click on the Edit posts function I will mostly just get a blank screen – I think it’s known as the “white screen of death”.

    Also when I try to save something, a new post for example I sometimes get the Error 500 message.

    If no one can help me, can someone please tell me how I can “Officially” report this to WordPress. I am not a newbie when it comes to systems and I have tried everything I can think of.


    There is nothing to report – this isn’t a bug.

    You need to make sure all of /wp-admin files are there

    If you are getting blank screens that is indicative of php issues or low php memory – you can ask host to bump memory to 32M and look at your host’s error logs for a clue.


    Thanks for the reply. I have already installed the entire /wp-admin directory (twice now) and everything seems to be there. I’ve also confirmed with phpinfo() that there appears to be enough memory – “memory-limit” is set to “40M”. Additionally, “error_log” is set to “no value” so it would seem errors aren’t being logged.

    I would be grateful for any other suggestions. This is annoying me. Oh yeah, the server is running PHP Version 4.4.9 and MSQL client API version of “5.0.67”.


    is there any way you can run php 5.x.x ?

    I can put in a support ticket. However they’re one of the largest providers in Germany (1 & 1 Internet) and I’m not sure they would upgrade just for me.

    It’s worth a shot though, thanks! I’ll repost if anything transpires.

    OK, I am happy to report that under PHP 5.2.8 everything is working well know.

    My provider already had PHP5 on the server but all PHP calls were being automatically handled by PHP4.

    I learned that the inclusion of the following two lines at the beginning of your .htaccess file in your blog’s root directory solved the problem.

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    Cheers, and thanks for pointing me in the right direction. Perhaps this info could be added to a FAQ somewhere.

    Thanks for posting this fix. I hadn’t changed anything on my site in months, running WP 2.6, and this Internal Server Error popped up today. I did a bit of Googling and found this post.

    I copied and pasted the code above into my .htaccess file and it got rid of the error.


    Just wanted to add my thanks for adding the above code to this thread – I’ve been getting 500 errors since I upgraded. Now I’m free and clear. Cheers!

    Thanks for posting this, this fixed the same problem I had when upgrading to 2.8. The edit posts page came up but none of the posts did. Kudos!

    Thank you so much for posting this and the fix! I upgraded to 2.8 and short of pulling my hair out. This solved my Error 500 – Internal Server Error problem.

    I’m working with 2.9, hosted on 1&1. When I upped the number of posts per page in the Edit Posts, up popped Error 500…which I had never seen before…and just couldn’t get rid of, though everything else worked.

    Thanks Webswift for those 2 lines of code! Worked like a champ!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Error 500 error and cannot edit my Posts (after 2.7 install)’ is closed to new replies.