Support » Plugin: Advanced Ads – Ad Manager & AdSense » Error 500 after last Plugin Update

  • Resolved gwerdi

    (@gabberkopf)


    Hello
    I just updated the advanced ads plugin to the latest version. Unfortunately now my blog and also admin backpanel gives me an Error 500. When i disable the advanced ads plugin through ftp access the page loads normally.

    Server Error logs shows:

    I: server “/var/run/hcgi/36137” stderr: PHP Fatal error: Uncaught Error: Call to a member function get() on null in ***/wp-includes/query.php:28
    ****
    FastCGI: server “/var/run/hcgi/36137” stderr: #8 ***/wp-content/plugins/advanced-ads/classes/ad-model. in ***/wp-includes/query.php on line 28

    any recommondation how to fix?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Thomas M

    (@webzunft)

    Hi gwerdi,

    thanks for reaching out.

    I am sorry for the problem you are experiencing. I updated the plugin on many of our sites, including the main plugin page and didn’t find any issue.

    The only place where we use the ad-model mentioned in the error is the new Gutenberg support. Are you using a beta version of WordPress or that feature plugin already? Otherwise, this code is not reached.

    Thomas

    Thread Starter gwerdi

    (@gabberkopf)

    Hi Thomas
    thank you for your reply

    I use the last WordPress version and no beta. Also I don’t use the gutenberg plugin. But I use quite a lot of plugins (yoast seo, etc) and Avada Theme which has it’s own fusion builder text editor. I tried to disable some of the other plugins but no success yet.

    Edit: My WordPress blog is running under PHP 7.2. which might be a reason for the error as I had some plugins in the past which weren’t compatible with php 7.2

    • This reply was modified 3 years, 1 month ago by gwerdi.
    Plugin Author Thomas M

    (@webzunft)

    Thank you for your reply.

    https://wpadvancedads.com is also running on 7.2 and the plugin worked there, as does it on my local dev environment, which is also on 7.2 right now.

    Did you disable all other plugins for testing or only some?

    You can also use the troubleshooting mode of the Health Check plugin to disable all plugins and enable Advanced Ads only for you. Visitors to your site will keep seeing the site without changes.

    Thomas

    Thread Starter gwerdi

    (@gabberkopf)

    I was trying with the health check plugin but unfortunately I have to rename the advanced-ads plugin folder through ftp to even get to the admin panel and activate the troubleshooting mode. Then I can’t enable the advanced ads plugin in this mode.

    Plugin Author Thomas M

    (@webzunft)

    Hi gwerdi,

    could you please contact me through our support page and share a screenshot of the issue you have with enabling Advanced Ads during troubleshooting mode?

    Thanks
    Thomas

    Thread Starter gwerdi

    (@gabberkopf)

    Hi Thomas

    I just sent you the screenshots through the support page. Meanwhile I inserted the google adsense code directly into my blog over my theme. So it’s not an urgent problem.

    Plugin Author Thomas M

    (@webzunft)

    gwerdi and I decided to close this ticket since we are not able to reproduce it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Error 500 after last Plugin Update’ is closed to new replies.