Support » Plugin: Download Monitor » Error 500

Viewing 8 replies - 1 through 8 (of 8 total)
  • I am having the same issue if I use any setting other than the Default Permalink setting. I have tried all the other permalink settings and every one but the deafult causes the 500 error. Have you found a solution to this issue?

    Could you post the url of the download link? Check your .htaccess file is showing the default

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Hi,

    I am still facing this error, tried dozens of htaccess variants, re-installs, database clean ups, database upgrades, permalink structures, chmod settings etc. Still no results.

    Is there any other reason?

    The downloads are all on this page http://www.campusrecruitment.eu/kennisbank/documentatie/

    Thanks!

    Try looking into the webservers error.log it will often give hints as to the nature of the error

    Hi Tomontoast,

    Thanks for your reply. Unfortunately I can’t discover any hints from the log. For example here’s a record of the download.php script.

    [17/Dec/2012:23:47:49 +0100] “GET /wp-content/plugins/download-monitor/download.php?id=5 HTTP/1.1” 500 403 “http://www.campusrecruitment.eu/kennisbank/documentatie/” “Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0”
    66.249.76.124 – –

    If you want I can sent you the whole log?

    Thanks again!

    There is a 403 error being called. This is often due to incorrect file permissions see http://codex.wordpress.org/Changing_File_Permissions Try changing file permissions temporarily to 777

    I am trying to run this on a windows server. I change the default permalinks in the settings (does not matter what option I choose), and this plugin is the only one that breaks. All other pages show the “pretty” permalinks and work without any issues.

    I did not change the custom URL for this plugin.

    The error message is http error 500.50 – URL Rewrite Module Error
    This page can not be displayed because an internal server error has occurred.

    I do not have a choice but to run this on a Windows Server. The person I am helping with this is very insistent that this needs to be a windows server as they are hosting multiple sites on this server and some of them are using ASP.

    I created a web.config file and checked the permissions on this file and the entries in this file. Everything is correct.

    juri003

    (@juri003)

    Hi tomontoast,

    Again, thanks.

    Unfortunately it still doesn’t work. Ik set the changemods to 777 for the following folders and files:

    /wp-content/plugins/download-monitor
    /wp-content/plugins/download-monitor/download.php
    /wp-content/uploads/
    /wp-content/uploads/downloads/
    /wp-content/uploads/downloads/2012/
    /wp-content/uploads/downloads/2012/12
    /wp-content/uploads/downloads/2012/12/some-file

    Other than that I removed some oher plugins like db-manager and wp-super-cache, all without result.

    Any other ideas maybe, you can have a look if you want.

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Error 500’ is closed to new replies.