Support » How-To and Troubleshooting » Error 500 1and1 – usual fixes not working

Error 500 1and1 – usual fixes not working

  • I have a wordpress site for a photographer. Someone was doing some simple CSS changes when the dreaded error 500 appeared. The site doesn’t load and wp-admin results in this: http://www.tetphotography.com/wp-admin/

    Error 500 - Internal server error
    An internal server error has occured!
    Please try again later.

    My host is 1and1. I have had similar problems before and so modified the .htaccess file. It now looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !http://www.tetphotography.com
    RewriteRule (wp-content/uploads.*\.(gif|jpg|jpeg|png)$) http://www.tetphotography.com/wp-content/plugins/hotlink-protection/forbid.png [L]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
        Options All -Indexes
        AddType x-mapp-php5 .php
        AddHandler x-mapp-php5 .php
    # END WordPress

    I also created a php.ini file with the content:

    Unfortunately, none of these fixes have resolved the issue. I’m a little confused since visiting the site itself just results in a blank page: http://www.tetphotography.com/. Only the WP-Admin produces the error 500.

    1and1 support weren’t great. They had this to say:

    Thank you for contacting us.

    We tried to check the version of php running on that website and it is now showing php 5.2.14 but still the admin panel shows error 500.
    Normally, parsing to php 5 is the solution but in your case it won’t work. We tried to check your .htaccess file and you got some rewrite rule in it.
    Have you asked wordpress for inputs about this? Can you please ask them first for some advice on what we need to check here on our servers?
    Technically, we don’t know how wordpress was built and its structure.

    If you have any further questions please do not hesitate to contact us.

    Much appreciation if anyone can help me here, or even just take a minute to point me in the right direction?


Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    i have a site hosted by 1 and 1 and get the same whenever i try to upload a new menu item to my custom menu. The error only appears in my admin panel; the site appears fine to visitors. I also don’t seem to have any problems updating pages and posts.

    I have tried pretty much all the solutions suggested on the forums including:

    creating a php.ini file that says

    ‘memory = 30MB(this is the maximum limit allowed by 1 and 1)
    # Disables register_globals for security reasons
    register_globals = ‘off’`  

    and editing my .htaccess file to read:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    Options All -Indexes
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php
    # END WordPress

    i deleted all but one (akismet) the plugins, and deactivated akismet.

    I made sure the version of wordpress I’m using is up to date.

    i have reuploaded the wp-admin and wp-includes files from a fresh download of wordpress, like esmi suggested.

    The test version of the site is up and running on another hosting provider without any problems, so I’m positive it’s not a theme related issue. I have called the 1 and 1 tech support, and they advised me to bring up the issue on this forum. (they clearly don’t have a clue.)

    anybody out there with any more suggestions for me? would be much appreciated!

    thank you!

    Stumped by this here, too. Have 43 menu items now and can’t add another one — crashes every time. The detailed error msg is

    [Sat Jun 25 10:28:43 2011] [error] [client] (104)Connection reset by peer: FastCGI: comm with server “/var/chroot/home/content/m/a/n/manicolaus/html-x-httpd-php5” aborted: read failed
    [Sat Jun 25 10:28:43 2011] [error] [client] FastCGI: incomplete headers (0 bytes) received from server “/var/chroot/home/content/m/a/n/manicolaus/html-x-httpd-php5”

    I’ve tried all the magic mojo lines in the php.ini file to no avail.

    I found a new way to solve the error 500. I create a page for everyone here: http://error5001and1.luciendubois.net
    Tell me if it works

    Thank you so much! I created the .htaccess file and placed it in the root directory of my 1&1 WP site. (The same directory that contains the “wp-admin,” “wp-content,” and “wp-includes” directory.) Worked like a charm! Those 2 lines of code are all it needed. I used your lines that said:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    I appreciate the time you took to write down the instructions.
    Thanks again!

    @luciendub, I appreciate you so much for giving back to the community and now so does my client.

    @bk @tigron It’s a pelasure for me to share it. I’m happy if it helped you! Feel free tp “+1” it or “like” it on the page 😉

    Not to rain on your parade, but when I applied your fix to my .htaccess file running WordPress 3.3 (alpha) on GoDaddy, it completely broke the site — admin menu crashed to code page, nothing could be saved, total disaster. I have no idea why, except that GoDaddy already has PHP 5.x installed so this code, which seems to virtualize 5 when running 4, causes havoc. Or maybe it’s the WP alpha. Time will tell.

    @manicolaus I’m sorry to hear that. As you said, I think it could be the alpha version or the fact that there is already php5 so you don’t need to add it again. Note that I already heard about wordpress websites that strested to creashed after a while even when the user didn’t touch to the .htaccess. So it could come from a extension or a bug

    I recently had the same Error 500 page and my domain hosting company said they fixed it by DISABLING the .htaccess file. My blogs (2) work fine now.

    Don’t know what “disabling” means: commenting out parts of the file or changing the name/suffix? But what does that mean for the oepration of WP? Is the .htaccess file like my appendix? No further value?

    I have only started having these failure problems since I downloaded the most recent update. Something smells.

    I see from the blog that a feature freeze for 3.3 is near.

    PLEASE FIX THE MENU PROBLEM that has been the subject of numerous user requests and complaints for over a year. One of the several threads about it is http://wordpress.org/support/topic/rc32-menus-still-crippled?replies=28

    It’s time for WP to GROW UP!

    I’ve been using 3.3 aortic-dissection dailies and the MENU PROBLEM IS NOT YET FIXED. If you don’t fix it, developers of sites requiring bigger menus will GO AWAY.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Error 500 1and1 – usual fixes not working’ is closed to new replies.