Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Yannick Lefebvre

    (@jackdewey)

    Were you on 7.0.4 previously or on an older update? 7.0.05 only introduced changes to the broken link checker, so it does not change anything that could introduce 500 errors.

    Have you tried enabling error logging on your site via the wp-config.php file, then checking the resulting log (located in /wp-content/debug.log) to see what the problem might be?

    The lines to have in your config file are:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    If you had not updated in a while, then we’ll have to look deeper into what is causing this issue on your site.

    Thread Starter Han Leentvaar

    (@hleenwp)

    Hi Yannick,

    I reinstalled the plugin, but the problem is related to bad (slow) hosting with very little memory.
    Thanks for your advice!

    Regards, Han Leentvaar

    Thread Starter Han Leentvaar

    (@hleenwp)

    Hi Yannick,

    I always keep plugins up to date, but I dived a bit deeper into the problem, as the user told me this only occurred on the search page. I found that The search page now always shows results, also when nothing is entered into the search field.
    This results in fetching ALL links, paginated. The maximum is set to 250, which does not seem to be respected.

    My code on the page is

    [link-library-search settings=3]
    [link-library settings=3]

    I can supply the library settings if that may help. In the common tab “Hide serach results when empty” is (and was) set to true.

    I also notice that I do not get any output in the log files, although I did turn the debugging on. But I experience that on other sites too.

    • This reply was modified 3 years, 1 month ago by Han Leentvaar.
    • This reply was modified 3 years, 1 month ago by Han Leentvaar. Reason: New test results
    Thread Starter Han Leentvaar

    (@hleenwp)

    I notice that the error 500 is mainly caused by the setting “pagination”.
    When I turn that off the rendering speed is much higher, error 500 is not the problem anymore.
    However, links are still visible without entering a search term, although “Hide is empty” is set to true. But the maximum is respected now (when pagination is turned off).

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    The ‘Hide results if Empty’ option just makes it so that nothing appears if there are no links to show. In your case, there are links to show. I think what would do what you want would be to check the option labeled ‘Only show one category at a time’ as well as the option ‘Hide category on start in single cat mode’. This way, it would not show any links from the start, and would then show you results when you search.

    Thread Starter Han Leentvaar

    (@hleenwp)

    Hi Yannick,

    checking the option ‘Hide category on start in single cat mode’ did the trick.
    When I also enable ‘Only show one category at a time’ I do not get search results.
    Problem solved, thanks for your support!

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    Excellent! Glad to hear we found something that works for your needs 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Error 500’ is closed to new replies.