• Resolved Holden86

    (@holden86)


    Hello,
    thank you for plugin but it continually generates errors.

    [26-Jan-2015 00:04:33 UTC] PHP Warning: is_readable(): open_basedir restriction in effect. File(/home/ojustnev/public_html/wp-content/plugins/google-news-editors-picks-news-feeds/bgnp-main.php/languages/google-news-editors-picks-feeds-it_IT.mo) is not within the allowed path(s): (/home/ojustnev/:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/ojustnev/public_html/wp-includes/l10n.php on line 476

    [26-Jan-2015 00:04:33 UTC] PHP Warning: is_readable(): open_basedir restriction in effect. File(/home/ojustnev/public_html/wp-content/plugins/google-news-editors-picks-news-feeds/bgnp-main.php/languages/google-news-editors-picks-feeds-it_IT.mo) is not within the allowed path(s): (/home/ojustnev/:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/ojustnev/public_html/wp-includes/l10n.php on line 476

    https://wordpress.org/plugins/google-news-editors-picks-news-feeds/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author PPDPurveyor

    (@peoples_pundit)

    That’s a bit vague for me to diagnose with access. Email me at ppd.ventures.llc@gmail.com – but just a quick question — have you attempted to translate the plugin?

    Plugin Author PPDPurveyor

    (@peoples_pundit)

    Holden86 and I are emailing each other. So, in case anyone else has this problem, it’s not an issue with the plugin, but rather with the host server settings. The problem you’re having is the result of restrictive security settings on your server.

    How to solve this:

    1) Fix it by setting “none” in “open_basedir” in the php settings of your Plesk, WHM or similar panel. Basically, defaults for those panels (save for WHM) will restrict access to files outside of your web folder.

    2) Copy and paste the error in full and send it to your web hosting support service. Ask them to create an exception for the folder that will loosen or remove the open_basedir restrictions, because it is not permitting access to the Google News Editors Picks Feed Generator plugin. They will know what to do. If they will not assist you or do it, then you should consider changing hosts, as your hands will be tied on other plugins, as well.

    3) There are no other options for resolving this issue other than set_include_path(‘.’); BUT DO NOT DO THIS ALONE! If granted access, I will do this as an absolute last resort for premium plugin license holders.

    Plugin Author PPDPurveyor

    (@peoples_pundit)

    I haven’t heard back, so I am going to mark this as resolved. You have my email if you need me.

    All the best!

    Hello, i upgrade the plugin but now it can’t show new articles.

    Plugin Author PPDPurveyor

    (@peoples_pundit)

    Hello Holden,
    I responded via email, but for others, it now excludes by default. Check the boxes to include articles now. We received a number of requests to change that, so we did.

    I can’t open the section on single article, it’s close.

    With new version “Check the boxes to include articles now” isn’t available. Try to open an article and you will see you can’t do anything because isn’t open. Holden86 have right, you should fix it.

    Plugin Author PPDPurveyor

    (@peoples_pundit)

    Can either one of you open a new thread and send me a screenshot.

    Do you mean the meta box isn’t open?

    Plugin Author PPDPurveyor

    (@peoples_pundit)

    Yeah, I forgot a line of code on the update. I see it. Give me a few minutes, I’ll shoot out the new updated file.

    Plugin Author PPDPurveyor

    (@peoples_pundit)

    You’re good now.

    Hallo, i have same error:

    PHP Warning: is_readable(): open_basedir restriction in effect. File(/home/xxx/public_html/wp-content/plugins/google-news-editors-picks-news-feeds/bgnp-main.php/languages/google-news-editors-picks-feeds-it_IT.mo) is not within the allowed path(s): (/home/xxx/:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/xxx/public_html/wp-includes/l10n.php on line 476

    Seems that this path is wrong: /bgnp-main.php/languages

    bgnp-main.php is a file not a folder…
    Maybe is this string wrong:

    load_plugin_textdomain( ‘google-news-editors-picks-feeds’, false, bgnp_BASENAME . ‘/languages/’ );

    ????

    Plugin Author PPDPurveyor

    (@peoples_pundit)

    Look at the previous answer guys.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Error’ is closed to new replies.