Error 406 and disable mod-security does not seem to help (1 post)

  1. geekinfinance
    Posted 4 years ago #

    Hi all,

    I have a WordPress blog that is installed and whenever I tried to update the permalink, it gives me the following error:

    Not Acceptable
    An appropriate representation of the requested resource /wordpress/wp-admin/options-permalink.php could not be found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    So I did some Googling and put up .htaccess to all 3 locations: the public_html folder (root of the online folders), the wordpress folder (where I installed wordpress) and the wp-admin folder inside wordpress with something like this:

    # BEGIN WordPress
    <IfModule mod_security.c>
    SecFilterInheritance Off
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    # END WordPress

    The permission for all files are 644.

    However, it still does not work and I am getting the same error msgs.

    Could someone please help? I have talked to my ISP and disable modsecurity is not an option.


Topic Closed

This topic has been closed to new replies.

About this Topic