Support » Plugin: Gravity Forms DPS PxPay » Error 405

  • Resolved sholls9


    We set up a payment form about 6 months ago and then in the past couple of weeks it has stopped connecting to DPS/Payment Express. It just times out and says Error 405. We have spoken to DPS about it and they’ve said everything is ok from their end. We also have Woo Commerce on our site and that was working ok but now it too has stopped connecting.

    Any help / ideas would be greatly appreciated.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author webaware


    G’day sholls9,

    You’ll see a couple of entries come through from a bloke called Test Only — just me! 🙂

    So, the form isn’t currently going through to Payment Express, so I presume you’ve deactivated the feed for now. If not… best turn on logging and see what it’s saying.

    405 is an odd error for you to be getting. It should only happen if a POST is being sent to a URL that only allows a GET, or similar to that. I’ve rested both of my DPS Payment Express plugins (Gravity Forms and WP eCommerce) and they both work OK still, so it’s not likely to be the plugin.

    When I looked at your WooCommerce shop, I couldn’t attempt a checkout there because of a JavaScript error with ACF — Advanced Custom Fields. You should get that fixed or you won’t get any sales!

    A while back, I had to add a fix to the Gravity Forms add-on to stop WooCommerce’s DPS Payment Express add-on grabbing Gravity Forms payments. It’s possible that the WooCommerce add-on has been changed and is again interfering with the Gravity Forms add-on. I’ll see if I can track down a recent copy and see if it’s doing that again.

    Finally, have you ensured that your website is TLS 1.2 compatible? Install this plugin to check:


    Hi Ross,

    Thanks so much for your help with this. We had changed a setting to test something but the gravity forms are now back to how they were and it’s still going to a 405 error. I’ve added the logging reports and it’s coming back with a load of code – here’s the first few lines but let me know if you need more or different links:

    2018-07-24 3:51:23.111148 - DEBUG --> GFCommon::post_to_manager(): endpoint: 
    2018-07-24 3:51:23.790565 - DEBUG --> GFCommon::log_remote_response(): code: 200; body: <!--GFM--> 
    2018-07-24 3:51:23.792800 - DEBUG --> GFCommon::post_to_manager(): endpoint: 
    2018-07-24 3:51:24.076565 - DEBUG --> GFCommon::log_remote_response(): code: 200; body: 

    Thank you for the info on Woo Commerce we will work on that. I’ve tested our compatibility with the TLS 1.2 plugin to connect to Paypal and it says everything is ok except our cURL version is 7.19.7, and we should upgrade to cURL 7.34.0 or higher.

    Thanks again.

    • This reply was modified 2 months, 4 weeks ago by  Jan Dembowski.
    Plugin Author webaware


    G’day Sholls,

    First: your last message has your Gravity Forms key in it, so I’m hoping that a moderator will edit the message to obfuscate the key, or that you will! Don’t hand out your licence key.

    Now, I’ve obtained a copy of the WooCommerce add-on for Payment Express, and I can run the two payment add-ons together without problem. Here’s what I tested on:

    * WordPress 4.9.7 / PHP 7.2
    * Gravity Forms
    * Gravity Forms DPS PxPay 2.1.0
    * WooCommerce 3.4.3
    * WooCommerce Payment Express Gateway 2.8

    AH! Whilst typing this up, I was waiting on a very slow form submit on your website, which finally failed with an nginx 405 error. This indicates some problem on your server. You need to speak to your website host and get them to look at the server logs to see where this is failing.

    Because it’s taking a while to fail, I reckon it’s a network timeout somewhere along the line. Tell your host that the plugin is trying to connect to the following URL before redirecting to the Payment Express website, it might help them work out what the failure is.


Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.