Support » Plugin: Pods - Custom Content Types and Fields » Error 404 when editing or deleting PODS

  • Resolved memsoftware

    (@memsoftware)


    Hello people:
    (My English is poor, sorry)
    I’m practical with WordPress, I’ve been using it for years but this issue is bothering me a bit since I followed the most common procedures and some not so much and I could not fix it. The plugin is PODS, the plugin works great but when editing a pod (custom fieds) from the backend appears the dreaded 404 error.
    What I did was to first disable all the web plugins to leave only that, delete the .httaccess file and rebuild the permanent links. Also change the PHP version just in case. Desistale and I reinstalled the plugin and even went back to an earlier version of it … so and all the error persists. When I enter to administer the PODS and I want to delete some or edit some simply the 404 page of error appears. I need someone with experience in the subject that gives me a hand, before posting even look for some other less likely solutions such as redirects that did not work.

    The problem seems to be in all directions that edit from admin.php:
    Example:

    … wp-admin / admin.php? page = pods & action = edit & id = 379

    or

    … wp-admin / admin.php? page = pods & action = delete & id = 4081 & _wpnonce = 4f4748f1dd

    In other words, everything that has “& action =” gives 404 error.
    Recently I also installed versions before the plugin, updated WordPress, the theme and relice repairs of the database without success, I do not know where to take it.

    Thank you!
    Regards!

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Jim True

    (@jimtrue)

    My apologies for just now replying to you, typically if you have issues like this, you want to come to our Slack Chat so we can work with you directly and most quickly at https://pods.io/chat/

    What is the ‘name’ of the Post Type you’ve created? Checking to make sure there’s not a reserved word being used, like ‘year’, etc.

    Plugin Author Jim True

    (@jimtrue)

    Can you also let us know the version of PHP on your server?

    Hello:
    I have solved the problem. I post it so that someone will be given in case of having the same error. Apparently the plugin pods (in its latest version) was detected by the server’s firewall. I had done everything but I only realized when I cloned the site on another server. With the exit of the firewall (delete the blockade) everything worked again.

    Regards

    Plugin Author Jim True

    (@jimtrue)

    Your Server Host was blocking the plugin specifically?

    Plugin Author Jim True

    (@jimtrue)

    We actually had another one of these populate through yesterday. It would be helpful to have any information you can provide (your host, etc.) so we can update our FAQ’s on this one.

    Thanks!

    Hi Jim;
    They told me that the firewall had blocked it from within (so the plugin generated this error and the firewall blocked it).
    For your convenience, they sent me the address to understand the error:

    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-7957)

    It is seen that then I updated and the new version no longer worked.
    I hope I can help.
    I have other questions, I’m going to open another post to clarify them since I’m making Pods my main plugin on my website.

    A greeting!.

    Plugin Author Jim True

    (@jimtrue)

    Were you using the older 2.4.3 (or older) version of Pods and that’s why they firewalled it?

    We’ve added a FAQ for getting 404/403 on the back-end to redirect folks to their host to see if specific URL’s are being blocked.

    Definitely sorry for the inconvenience, but that version of Pods hasn’t been around for a long time (since 2014)

    Hi Jim:
    Sorry for the delay. Perhaps it has not been clear but the version of POD that was blocked by the firewall was not 2.4.3 but 2.7.10. I like that they have added that in the FAQs. Thanks for the support.

    A greeting.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Error 404 when editing or deleting PODS’ is closed to new replies.