Support » Networking WordPress » Error 404 – Dashboard not accessible – main site works fine – new installation

  • Resolved zahohie

    (@zahohie)



    Hi,
    because of this 404 error I installed Multisite once again on a fresh WordPress installation. This time I did it manually, first time I installed WP trough softaculous. Followed all the instructions for Multisite installation, always checking several times with several resources, to be sure I understand everything. I learned a lot, but the Error stays the same.

    The main site always works fine. But when I create a 2nd site I can’t access the dashboard:

    Error 404 – Not Found
    The document you are looking for may have been removed or re-named. Please contact the web site owner for further assistance.

    When I look at the site this shows up:
    Index of /

    Name Last modified Size Description
    cgi-bin/ 2018-06-15 07:16 –

    Hosting is at InMotion – shared host
    – support says Mod_rewrite is enabled and that the subdomain is pointed correctly

    Plugins deleted before Multisite enabled
    Pretty Permalink enabled
    Rechecked several times that config.php and .htaccess data is correctly displayed following the given instructions.

    config:
    /* Multisite */
    define( ‘WP_ALLOW_MULTISITE’, true );
    define(‘MULTISITE’, true);
    define(‘SUBDOMAIN_INSTALL’, true);
    define(‘DOMAIN_CURRENT_SITE’, ‘zahohie.com’);
    define(‘PATH_CURRENT_SITE’, ‘/’);
    define(‘SITE_ID_CURRENT_SITE’, 1);
    define(‘BLOG_ID_CURRENT_SITE’, 1);
    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */

    htaccess:
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    subdomains enabled, first with wildcard and now with direct subdomain, its always the same outcome of error.

    Theme: at this time only the default

    WP is installed at public_html as well as the subdomain folder

    database looks good – as far as I can see

    MySQL Version – 10.2.14-MariaDB-log
    PHP Version – 7.0.29
    Apache Version – 2.4.33
    Architecture – x86_64

    I do observe, that at the folder uploads/sites/{site ID} – there is nothing – the folder uploads only shows a folder 2018 within that a folder of 06 – which is empty because of the new installation. ???

    My IT knowledge is only gathered by slowly just doing, observing and throwing myself into the task, which sometimes overwhelmed, but I do learn…

    Hope someone can help here – would appreciate it a lot.
    Thanks!

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • forgot to mention:

    subdomain at this time is: test.

    you have used define(‘SUBDOMAIN_INSTALL’, true);

    make it define(‘SUBDOMAIN_INSTALL’, false);

    Thanks Vishal, but I’m using subdomains, so it has to be true.

    Found someone at WPMU DEV who could fix the Error for me.

    The issue was a wrong setting of the wildcard subdomain at the hosts account in CPanel.

    Hi zahohie,
    Can you please put the details of how you fixed this here? I am am having the exact same issue as you did and I can not get it fixed.

    • This reply was modified 1 month, 1 week ago by  darenjm.

    Hi darenjm,
    received your mail, and trying to remember how it was resolved, I saw you are also posting here.
    So I’ll answer your question here to serve maybe others as well.

    As I remember the main issue was at CPanel => Subdomains
    Create the new subdomain: choose your name or wildcard
    – under “Document Root” it has to point directly to /public_html (nothing before the slash)

    that’s it.

    Hope it works for you.

    Hi Zahohie,
    That’s exactly right. I go on chat with Kris at WPMU DEV and he was able to help me solve it. But thanks to you I knew where to look, so thank you.

    Hi Daren,
    Yes it was Kris at WPMU DEV who resolved my issue as well. Great job he did!!!
    Glad I could ad something.

    Timothy Bowers

    (@gmax21)

    WPMU DEV Support Staff & WCEU Contributor Day 2016

    I love Kris too, he does a grand job! 🙂

    Thanks for sharing your experience.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.