Support » Plugin: Simple URLs » Error 404 after update

  • Resolved scottvs168

    (@scottvs168)


    I am getting the Error 404 page after this last update.
    I attempted the usual fixes with no success.
    After doing some testing I found that only the Simple URL links older than 6 months were getting the 404 error.
    I am in the process of saving my older links to a published date of yesterday which solves the problem.
    This is quite time-consuming. Any ideas for an easier fix and how I might avoid this issue again in 6 months?

Viewing 15 replies - 1 through 15 (of 23 total)
  • scottvs168

    (@scottvs168)

    Scratch that idea. Updating the published date is not a solution as it appears only the 10 most recently published links are working and the rest get the 404 error code.
    It was also only the 10 most recent links that were working before I did the updates.
    Now 7 of the 10 working links are different since before I changed published date for all links.
    I have no idea why this is the case. Help.

    • This reply was modified 6 months ago by scottvs168.
    scottvs168

    (@scottvs168)

    Does this code have anything to do with it?
    add_filter( ‘allowed_redirect_hosts’, array( $this, ‘add_allowed_redirect_hosts’ ), 10 );

    normang34

    (@normang34)

    Did you ever get this figured out? It seems hit or miss as to which of my URLs weren’t working properly after the update, but a lot of them were broken. Ended up reverting to the old version for now until it gets sorted out.

    Plugin Contributor marksabbath

    (@marksabbath)

    Hey, @normang34 @scottvs168 have you tried to re-save the permalinks + clear the cache (including the object cache if exists)?

    normang34

    (@normang34)

    I’ll give that a shot – thanks!

    Tevya

    (@thefiddler)

    I’m not sure if I’m having the same issue, because I’m not getting a 404. But it seems like the same thing: some links work fine, others do not. Seems like maybe older links don’t work, but newer ones do. The ones that don’t work redirect to /wp-admin/. You can see one here: https://wordx.press/go/wp-rocket-plugin/

    This is bad, it means almost all my affiliate links aren’t working (and haven’t been for who knows how long…?)!

    I did clear both WP Rocket’s caching, and the nginx/server stack caching. No change.

    • This reply was modified 6 months ago by Tevya.
    scottvs168

    (@scottvs168)

    I couldn’t wait around for the usual “permalinks” answer so I switched to a different plugin. I tried several things to fix this plugin, but it was always only the 10 most recently saved urls that were working.

    Tevya

    (@thefiddler)

    What one did you choose? I can’t leave my sites like this….

    scottvs168

    (@scottvs168)

    I am using the free version of ThirstyAffiliates and I am happy with it.

    Tevya

    (@thefiddler)

    Does it let you mimic the URLs of this plugin, like /go/wp-rocket-plugin/ ? I don’t want to have to go back and update all my links in blog posts, etc….

    scottvs168

    (@scottvs168)

    I spent a few hours copying and pasting all my links to the new plugin

    Tevya

    (@thefiddler)

    Hey @marksabbath any chance we can get some word on if this is something you’re looking into and can fix soon? I’d rather not have to do what Scott did. I really like the simplicity of this plugin.

    Plugin Contributor marksabbath

    (@marksabbath)

    Hey @thefiddler I’m currently investigating this case, but I’m not able to reproduce this in my development environment.

    What I’ve been doing to try to reproduce this error is:

    – Install an older version of the plugin;
    – Create a few redirects, make sure they work;
    – Update the plugin;
    – Check if the links are working.

    Using this environment, I’m always getting the links working.

    I was able to get some sort of error just like you’re reporting, but not after updating the plugin, but when updating the slug using a filter. To resolve that, I’ve re-saved the permalink and it started to work. Another option would be running a wp-cli command like wp rewrite flush --hard.

    Since you’ve tried re-saving the permalinks and it seems that this didn’t work, would you mind trying to run wp rewrite flush --hard?

    Tevya

    (@thefiddler)

    Hey @marksabbath thanks for looking into this!

    I’ve never used WP-CLI. I’m happy to setup a staging copy for you to play with, or even let you look at the live site. You can run that yourself on either of those.

    I’ve resaved permalinks though, flushed the WP Rocket and server (I believe our host uses both memcached and nginx) cache, and the same thing is still true: the ~10 most recent work great. But the rest do not.

    If you want access to one of our sites, just shoot me a message through our contact form: https://wordx.press/contact/ or whatever works for you.

    I just checked my other site that’s using it, and it doesn’t have this problem. It’s on the same hosting (same server, I think). So it’s like something is just “stuck” on this particular site…. Or perhaps a plugin conflict? I just can’t imagine how another plugin would allow 10 to work but block the rest. Seems like something else….

    Tevya

    (@thefiddler)

    Oh! I just saw that the other site is still using an older version of the plugin. It’s on 0.9.7, and I’m not going to update to 0.9.8.

    I might try downgrading the other site and see if that helps….

Viewing 15 replies - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.