• Resolved ald182

    (@ald182)


    Hello,

    I have a problem, since version 5.1.2

    If I leave the plugin active, whether it’s version 5.1.2, 5.1.3 or 5.1.4, I systematically get the 403 error.

    For me to be able to use the plugin, I have to stay on version 5.1.1 and there it works correctly.

    Can you help me fix this problem so I can update the plugin?

    Thank you!

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Support hjogiupdraftplus

    (@hjogiupdraftplus)

    Hi @ald182

    Can you please let me know you have issue for login page or whole website?

    If for login access issue do you have IP whitelist enabled and IP got changed ?

    define( ‘AIOS_DISABLE_LOGIN_WHITELIST’, true ); in wp-config.php and try.

    If the site shows 403 error

    Try remove the code in .htaccess

    BEGIN All In One WP Security

    END All In One WP Security

    Let me know if still issue.

    Hi
    me too!
    
    If I go to the usual set-up 'WP Security hidden' login page, I am having exactly the same problem... 
    
    I get:
    
    
    Access to www.mydomain.com was denied
    You don't have authorisation to view this page.
    HTTP ERROR 403
    
    
    Last update and nothing to do with my IP.
    In-fact if I go to the standard WP login page - i.e. mysdomain.com/wp-admin, I see it.
    
    #.htaccess#
    If I upload older .htaccess, no change
    Also, when I go and check current .htaccess, there is no whitelist !
    
    I am confused.
    
    If I take .htaccess off, whole site goes 403.
    
    As it is, site is accessible, 403 on admin only.
    
    Thanks
    M
    • This reply was modified 1 year, 6 months ago by astr0wp.

    In the meantime I had to rename and do the usual …

    Problem is, I have not done anything !

    I even installed down to 5.1.1 and also deactivated all plugins.
    No change
    Then I installed an older version 4 and work s fine!

    It did happen to me maybe a year ago and went back to one of the 4 versions and worked.

    Just so you know.

    Managed to have the 5.0.9 version working.

    That is it. Tired to try and try.

    I know mine is a free version, but … all the same.

    Happy Christmas

    • This reply was modified 1 year, 6 months ago by astr0wp.
    Thread Starter ald182

    (@ald182)

    Hi @hjogiupdraftplus,

    Thank you for your message.

    This is for the whole site. I have to rename the plugin folder to disable it to access the site, when I update it.

    It’s not a login or whitelist problem since version 5.1.1 works. It’s the upper ones that don’t work.

    I already tried removing the code in .htaccess and the problem is still there.

    Plugin Support hjogiupdraftplus

    (@hjogiupdraftplus)

    Hi @ald182, @astr0wp

    I will try check in more detail can you please let me know the server you are running the site is it nginx / lightspeed ?

    Hi
    I may have found ‘a problem’

    Since I did not do anything, maybe your coding causes this problem when or if HOST company changes IP!

    Mine recently changed where they host their customer sites = changed IP.
    No, it is not nginx / lightspeed and it only happened to one of the sites on same shared linux server… in my case
    Just an idea.

    Plugin Support hjogiupdraftplus

    (@hjogiupdraftplus)

    Hi @astr0wp

    If you have login whitelist IP enabled and your IP is not static then it might be issue. Disable login white list and check it that is the issue.

    Add define( ‘AIOS_DISABLE_LOGIN_WHITELIST’, true ); in wp-config.php and try check.

    Please enable it only if you have static IP.

    WP Security > Settings >> Advanced IP detection method > set it to make sure correct IP detected and IF there it keeps changing to not enable login whitelist instead try rename login and cookie based brute force enabled.

    Thread Starter ald182

    (@ald182)

    Hi @hjogiupdraftplus,

    I am on neither of the 2 servers. I am on ovhcloud.com

    Plugin Support hjogiupdraftplus

    (@hjogiupdraftplus)

    Hi @ald182

    ovhcould.com seems hosting provider not the actual server your website running. you may ask your hosting provider exact details.

    Regards

    Thread Starter ald182

    (@ald182)

    It seems so though. I can’t find any conflicting info.

    Plugin Support hjogiupdraftplus

    (@hjogiupdraftplus)

    Hi @ald182

    Ok, Basically 403 error issue comes due to the login whitelist enabled and IP gets changed if any other issue needs to know the details of it that is why asking. Do you have still the issue ?

    Regards

    Thread Starter ald182

    (@ald182)

    Hi @hjogiupdraftplus

    The IP address is not changed and the login whitelist was never enabled.

    Also as said before, the 403 error occurred when updating the plugin and nothing was changed.

    Yes I just updated the plugin and still the 403 error.

    Regards

    Thread Starter ald182

    (@ald182)

    To see if there is a conflict with one of the plugins I use, I tested the problem by disabling them one by one.

    The only one I haven’t deactivated in my thirties is woocommerce. Without any plugin (except woocommerce) as soon as I go to update I always get 403 error.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Error 403 since update 5.1.2’ is closed to new replies.