• Resolved bertswaans

    (@bertswaans)


    Problems with authentication photonic. I followed documented steps for Api, auth 2.0,…
    When I continue and go to authentication part, I get 401 error.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Sayontan

    (@sayontan)

    Can you provide some details? What is the error message? Can you provide me with some screenshots?

    bertswaans

    (@bertswaans)

    401. That’s an error.

    Error: invalid_client

    The OAuth client was not found.
    Request Details

    That’s all we know.

    That was the error message. Don’t know how to include scrshot

    Plugin Author Sayontan

    (@sayontan)

    Which step are you seeing this in?

    bertswaans

    (@bertswaans)

    The authentication part 1

    Plugin Author Sayontan

    (@sayontan)

    Sorry, I am having a hard time understanding. Please see the documentation link (http://aquoid.com/plugins/photonic/google-photos/). Which step here is causing a problem?

    bertswaans

    (@bertswaans)

    Ah ok.

    this part of the documentation

    Authentication (🔗)

    To set up authentication you will need to do the following:

    The first step requires you to set the Google Client ID and Google Client Secret at Photonic → Settings → Google Photos → Google Photos Settings.
    Next, head over to Photonic → Authentication → Google Photos, then start the authentication:

    I don’t get to step 3. I don’t get the login screen. There I get the error

    Plugin Author Sayontan

    (@sayontan)

    A few questions:

    1. Are you moving over from a different plugin that you were using for Picasa? If so, are you using your client ID from that plugin?
    2. Are you moving over from the Picasa module of Photonic itself? If so, are you using the client ID that you created for the Picasa module?
    3. Are you setting up Photonic from scratch, but using a previously defined client id?
    4. Have you performed these steps to enable the client for the Google Photos API?
    bertswaans

    (@bertswaans)

    No, starting from scratch, with new client id.
    Google photo’s api is enabled, as stated in the steps.

    bertswaans

    (@bertswaans)

    The google account is starting from gsuite (schools and education) Maybe there is a conflict with that…

    Plugin Author Sayontan

    (@sayontan)

    OK, it looks like you either have a security plugin or one of the security settings on your host is conflicting with Photonic. I added a section for an authentication workaround on the documentation page. Please try the steps there.

    The google account is starting from gsuite (schools and education) Maybe there is a conflict with that…

    No, there are multiple people who use Photonic with G-Suite accounts. You shouldn’t have an issue because of that.

    Plugin Author Sayontan

    (@sayontan)

    Let me know if the workaround helps.

    It is not ideal, but the only way for me to get around that is to provide my own API key … and I cannot do that because Google imposes a limit of 10,000 calls per day and Photonic has way too many users for 10,000 calls to be sufficient.

    bertswaans

    (@bertswaans)

    Solved.
    Thx for the help

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘error 401 photonic/google photos’ is closed to new replies.