• I went through all the steps in your documentation, and successfully generated both Client ID and Client Secret tokens, but when I get to Authentication > “Step 1: Authenticate” I get an error message from Google, “Authorization Error
    Error 400: redirect_uri_mismatch”

    Please advise!
    thanks,
    Pete

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Sayontan

    (@sayontan)

    What sort of a client id is this? Desktop or Web App?

    Thread Starter flatrock

    (@flatrock)

    Web app I think, remind me how do I tell?
    What ever I did, I followed the instructions from the link that was in the WordPress Dashboard

    Plugin Author Sayontan

    (@sayontan)

    In Google Console, if you click on the tab that says “Credentials”, it will tell you what type of an id it is. A Desktop client will not require a redirect URL (and is easier to set up), but a web app will. There are things you will have to ensure if you are using a web app, and you might have to employ a workaround. See the documentation – it lists out everything you need to do for the client setup.

    Thread Starter flatrock

    (@flatrock)

    okay, thanks I will try that and report back.
    Thanks for the quick response!!

    Thread Starter flatrock

    (@flatrock)

    It’s telling me it is in fact a Desktop client

    Plugin Author Sayontan

    (@sayontan)

    In that case there is something wrong with how Google set up the desktop client. Try setting up a new desktop client under the same project, and also ensure that you are following all the steps to “Publish” the app, plus you are adding the Google Photos app to the scope.

    If it continues to give you a problem, you might have to set up a web app client id.

    Thread Starter flatrock

    (@flatrock)

    okay, I’ll try that

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.