Support » Plugin: Nextend Google Connect » Error: 400 – Error: redirect_uri_mismatch

Viewing 1 replies (of 1 total)
  • Hello,

    I had a similar problem and it mysteriously resolved when I copied the URL that is provided in the /wp-admin/options-general.php?page=nextend-google-connect options page where you add your google credential.

    Item 8 say:

    Click on the more options link and copy and paste [a URL is provided here] to the text area.

    Item 8 deals with this part of the google credentials process:

    Authorized redirect URIs

    For use with requests from a web server. This is the path in your application that users are redirected to after they have authenticated with Google. The path will be appended with the authorization code for access. Must have a protocol. Cannot contain URL fragments or relative paths. Cannot be a public IP address.

    This section appears on the Credentials panel of your product declaration in the API set up process.
    I am assuming you got to this point.

    I don’t know why copying the redirect address from my NextEnd WordPress settings screen worked when copying it from the 404 page did not. Maybe it is a character set encoding issue. I hope this works for you.

    So, if you copy from the settings page, not from the error 404 page, the URL at item 8 which should look like : http://mydomain.com/wp-login.php?loginGoogle=1

    That should work. It did for me.

    • This reply was modified 2 years, 4 months ago by  karlazz.
Viewing 1 replies (of 1 total)
  • The topic ‘Error: 400 – Error: redirect_uri_mismatch’ is closed to new replies.