Support » Plugin: Cloudflare » Error 400. Bad requests, all the time.

  • Duke

    (@dukessa)


    As mentioned in another thread (which is almost 2 years old), the automatic cache management is unusable.

    Plugin and WP are the latest version.

    The plugin will produce a 500MB error log in less than 24h.

    Errors always look like this:

    [10-Apr-2019 15:39:11 UTC] [Cloudflare] ERROR: [CLIENT API] Array
    (
        [type] => response
        [reason] => Bad Request
        [code] => 400
    )
     
    [10-Apr-2019 15:39:11 UTC] [Cloudflare] ERROR: Bad Request 
    [10-Apr-2019 15:39:12 UTC] [Cloudflare] ERROR: [CLIENT API] Array
    (
        [type] => request
        [path] => https://api.cloudflare.com/client/v4/zones/ID/purge_cache
        [timeout] => 30
        [method] => DELETE
        [headers] => Array
            (
                [X-Auth-Key] => cb4e20f9b7294677cd7708d985a92c0a3140e
                [X-Auth-Email] => info@shambix.com
                [Content-Type] => application/json
            )
    
        [body] => {"files":["https:\/\/www.site.com\/?product_type=simple","https:\/\/www.site.com\/?product_visibility=exclude-from-search","https:\/\/www.site.com\/?product_visibility=exclude-from-catalog","https:\/\/www.site.com\/product-category\/mini-clutch\/","https:\/\/www.site.com\/color\/black\/","https:\/\/www.site.com\/color\/ribes\/","https:\/\/www.site.com\/color\/navy\/","https:\/\/www.site.com\/color\/canguro\/","https:\/\/www.site.com\/collection\/fw2017\/","https:\/\/www.site.com\/collection\/fw2017\/felina_fw2017\/","https:\/\/www.site.com\/author\/selena\/","https:\/\/www.site.com\/author\/selena\/feed\/","https:\/\/www.site.com\/shop\/","https:\/\/www.site.com\/shop\/feed\/","https:\/\/www.site.com\/product\/ribes\/","https:\/\/www.site.com\/feed\/rdf\/","https:\/\/www.site.com\/feed\/rss\/","https:\/\/www.site.com\/feed\/","https:\/\/www.site.com\/feed\/atom\/","https:\/\/www.site.com\/comments\/feed\/",null,"https:\/\/www.site.com\/","http:\/\/www.site.com\/?product_type=simple","http:\/\/www.site.com\/?product_visibility=exclude-from-search","http:\/\/www.site.com\/?product_visibility=exclude-from-catalog","http:\/\/www.site.com\/product-category\/mini-clutch\/","http:\/\/www.site.com\/color\/black\/","http:\/\/www.site.com\/color\/ribes\/","http:\/\/www.site.com\/color\/navy\/","http:\/\/www.site.com\/color\/canguro\/","http:\/\/www.site.com\/collection\/fw2017\/","http:\/\/www.site.com\/collection\/fw2017\/felina_fw2017\/","http:\/\/www.site.com\/author\/selena\/","http:\/\/www.site.com\/author\/selena\/feed\/","http:\/\/www.site.com\/shop\/","http:\/\/www.site.com\/shop\/feed\/","http:\/\/www.site.com\/product\/ribes\/","http:\/\/www.site.com\/feed\/rdf\/","http:\/\/www.site.com\/feed\/rss\/","http:\/\/www.site.com\/feed\/","http:\/\/www.site.com\/feed\/atom\/","http:\/\/www.site.com\/comments\/feed\/","","http:\/\/www.site.com\/"],"cfCSRFToken":null}
    )

    Any progress on this issue?

  • The topic ‘Error 400. Bad requests, all the time.’ is closed to new replies.