Support » Plugin: WordPress Landing Pages » Error 400 – Bad request

  • Resolved Jean0204



    I have a problem since I use this plugin. When I start modifying my landing page, after 3 or 4 refresh, I have an “Error 400 Bad request – your browser sent a request that this server could not understand”

    It appears on the latest version of FF, chrome and IE on every page (even my homepage sometimes) and I cannot access to wp-admin.

    I even tried on my phone, and I get the error…
    I asked my free host to know if it was a problem from them and I’m still waiting for the answer, but I saw another person had the same pb earlier.

    NB: When I clear my full internet history, after a few minutes I can access again, but then I have the same pb.

    Thanks for helping
    hosted by: hostinger

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author David Wells


    can you post link to landing page?

    Hi David,

    Here you go:

    Plugin Author David Wells


    looks like your theme is incompatible.

    Can you try building a landing page with a different template?

    Yes, here is the result for dropcap…

    So my theme isn’t compatible with your plugin? :/


    Again, bad request. After modifying a bit this template 🙁

    Plugin Author David Wells


    I can see the landing page at

    Can you screenshot or video your issue? I’m not seeing it here in chrome

    Plugin Author David Wells


    Now I see it.

    What does your htaccess file look like?

    Go into settings > debug for your htaccess file text

    Yep, here you go:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{QUERY_STRING} !lp-variation-id
    RewriteRule ^go/([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1  [QSA,L]
    RewriteRule ^landing-page=([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1 [QSA,L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Was it this?

    Plugin Author David Wells


    I am not sure what is causing the issue. The htaccess looks fine to me.

    It must be something with hostinger.

    It’s like the rewrite rules only work 5-6 times and then fail with 400 error.

    Do you have another hosting provider you can use?


    I can search for it… Actually this host sucks a bit, I already had some issues with them and wanted to move away from them.

    I have to backup everything and change my domain…

    What I can do is find another free host, put my theme on it, your plugin and all my others (to verify if there’s any conflict) and then try if it works or not.
    If yes, I’ll move my website hosted on hostinger and take my time… (I’ve never done this before :'()

    Do you think it’s a good idea?

    Plugin Author David Wells


    Thats the only thing I can think to do. We can’t reproduce the error on WPengine or Bluehost

    You could also test for plugin/theme conflicts

    To test for a theme conflict:

    1. Activate default Twenty Ten, Eleven, Twelve, or Thirteen theme
    2. Check to see if the issue still occurs
    3. If the issue does not occur after having activated the default “Twenty” theme, your theme is causing a conflict with landing pages.

    To test for a plugin conflict:

    1. Deactivate ALL plugins
    2. Activate Landing Pages
    3. Check to see if the issue occurs

    If the issue does not occur, one (or more) of your plugins is causing a conflict with Landing Pages.

    To determine which plugin(s) is causing the conflict, follow these steps:

    1. Activate each plugin one by one
    2. Check to see if the issue occurs after each plugin is activated

    Hi again,

    I finally have my old domain on which is way more serious.
    Here is the landing page:

    I don’t think it has any bug but the preview window which shows “404 error”… Do you know why?

    Last questions: how to hide the background and stop the border-radius?
    I tried this:

    width: 500px;
    background: none;}

    but only the width works. In Firebug I can see that: Image here

    One #content is crossed but not the other… so it doesn’t work.

    My second one is: Is it possible to put a landing page as a homepage? Because they don’t appear in Settings/Reading-Options/Static Pages…


    Plugin Author David Wells


    Great, thank you for everything David.

    Your plug in and you are awesome 😉



Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Error 400 – Bad request’ is closed to new replies.