WordPress.org

Forums

WordPress Landing Pages
[resolved] Error 400 - Bad request (18 posts)

  1. Jean0204
    Member
    Posted 1 year ago #

    Hi,

    I have a problem since I use this plugin. When I start modifying my landing page, after 3 or 4 refresh, I have an "Error 400 Bad request - your browser sent a request that this server could not understand"

    It appears on the latest version of FF, chrome and IE on every page (even my homepage sometimes) and I cannot access to wp-admin.

    I even tried on my phone, and I get the error...
    I asked my free host to know if it was a problem from them and I'm still waiting for the answer, but I saw another person had the same pb earlier.

    NB: When I clear my full internet history, after a few minutes I can access again, but then I have the same pb.

    Thanks for helping

    http://FrenchyInCali.bl.ee/
    hosted by: hostinger

    http://wordpress.org/plugins/landing-pages/

  2. David Wells
    Member
    Plugin Author

    Posted 1 year ago #

    can you post link to landing page?

  3. Jean0204
    Member
    Posted 1 year ago #

    Hi David,

    Here you go: http://frenchyincali.bl.ee/go/home/

  4. David Wells
    Member
    Plugin Author

    Posted 1 year ago #

    looks like your theme is incompatible.

    Can you try building a landing page with a different template?

  5. Jean0204
    Member
    Posted 1 year ago #

    Yes, here is the result for dropcap...

    So my theme isn't compatible with your plugin? :/

    http://frenchyincali.bl.ee/go/dropcap-test/

  6. Jean0204
    Member
    Posted 1 year ago #

    F......................!

    Again, bad request. After modifying a bit this template :(

  7. David Wells
    Member
    Plugin Author

    Posted 1 year ago #

    I can see the landing page at http://frenchyincali.bl.ee/go/dropcap-test/

    Can you screenshot or video your issue? I'm not seeing it here in chrome

  8. David Wells
    Member
    Plugin Author

    Posted 1 year ago #

    Now I see it.

    What does your htaccess file look like?

    Go into settings > debug for your htaccess file text

  9. Jean0204
    Member
    Posted 1 year ago #

    Yep, here you go:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{QUERY_STRING} !lp-variation-id
    RewriteRule ^go/([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1  [QSA,L]
    RewriteRule ^landing-page=([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1 [QSA,L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  10. Jean0204
    Member
    Posted 1 year ago #

    Was it this?

  11. David Wells
    Member
    Plugin Author

    Posted 1 year ago #

    I am not sure what is causing the issue. The htaccess looks fine to me.

    It must be something with hostinger.

    It's like the rewrite rules only work 5-6 times and then fail with 400 error.

    Do you have another hosting provider you can use?

  12. Jean0204
    Member
    Posted 1 year ago #

    Emmmmmmh,

    I can search for it... Actually this host sucks a bit, I already had some issues with them and wanted to move away from them.

    I have to backup everything and change my domain...

    What I can do is find another free host, put my theme on it, your plugin and all my others (to verify if there's any conflict) and then try if it works or not.
    If yes, I'll move my website hosted on hostinger and take my time... (I've never done this before :'()

    Do you think it's a good idea?

  13. David Wells
    Member
    Plugin Author

    Posted 1 year ago #

    Thats the only thing I can think to do. We can't reproduce the error on WPengine or Bluehost

    You could also test for plugin/theme conflicts

    To test for a theme conflict:

    1. Activate default Twenty Ten, Eleven, Twelve, or Thirteen theme
    2. Check to see if the issue still occurs
    3. If the issue does not occur after having activated the default "Twenty" theme, your theme is causing a conflict with landing pages.

    To test for a plugin conflict:

    1. Deactivate ALL plugins
    2. Activate Landing Pages
    3. Check to see if the issue occurs

    If the issue does not occur, one (or more) of your plugins is causing a conflict with Landing Pages.

    To determine which plugin(s) is causing the conflict, follow these steps:

    1. Activate each plugin one by one
    2. Check to see if the issue occurs after each plugin is activated
  14. Jean0204
    Member
    Posted 1 year ago #

    Hi again,

    I finally have my old domain on ovh.com which is way more serious.
    Here is the landing page: http://students-abroad.net/?landing-page=11

    I don't think it has any bug but the preview window which shows "404 error"... Do you know why?

    Last questions: how to hide the background and stop the border-radius?
    I tried this:

    #content{
    border-radius:0px;
    width: 500px;
    background: none;}

    but only the width works. In Firebug I can see that: Image here

    One #content is crossed but not the other... so it doesn't work.

    My second one is: Is it possible to put a landing page as a homepage? Because they don't appear in Settings/Reading-Options/Static Pages...

    Thx!

  15. David Wells
    Member
    Plugin Author

    Posted 1 year ago #

  16. Jean0204
    Member
    Posted 1 year ago #

    Great, thank you for everything David.

    Your plug in and you are awesome ;)

    Cheers,

    Jean.

  17. David Wells
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks Jean!

    If you like the plugin (or the support), we would love a quick review from you on the WordPress Plugin Repository, it would really help us out!

    You can leave a review here.

    Thanks and let me know if you have any questions about the plugin.

  18. Jean0204
    Member
    Posted 1 year ago #

    Done ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic