• Hello everyone,

    I’m using a multi-site with the newsest wp version.
    The Google Analytics Plugin (4.8.3) is network wide activated.

    After i’ve set up the plugin, everything works fine for a while. After some time, a few hours, days or a week, i’ll get an error on the dashboard: The report is not available, error: 400.
    The time period seems totally random.

    I dont’t have a lot of plugins activated:
    contact form 7
    ithemes security
    user role editor
    w3 total cache
    woocommerce
    wordpress mu domain mapping
    visual composer
    yoast seo

    Thanks for your help

    The error report shows:

    “exception ‘Google_Auth_Exception’ with message ‘Error refreshing the OAuth2 token, message:'{“error”:”invalid_grant”}
    In
    /wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Auth/OAuth2.php:331
    Stack trace:
    #0 /wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Auth/OAuth2.php(264): Google_Auth_OAuth2->refreshTokenRequest(Array)
    #1 /wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Auth/OAuth2.php(240): Google_Auth_OAuth2->refreshToken(‘1/H5jGt8KF9gdey…’)
    #2 /wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Service/Resource.php(215): Google_Auth_OAuth2->sign(Object(Google_Http_Request))
    #3 /wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Service/Analytics.php(1909): Google_Service_Resource->call(‘get’, Array, ‘Google_Service_…’)
    #4 /wp-content/plugins/google-analytics-dashboard-for-wp/tools/gapi.php(275): Google_Service_Analytics_DataGa_Resource->get(‘ga:110848844′, ’30daysAgo’, ‘yesterday’, ‘ga:sessions,ga:…’, Array)
    #5 /wp-content/plugins/google-analytics-dashboard-for-wp/tools/gapi.php(403): GADWP_GAPI_Controller->handle_corereports(‘110848844′, ’30daysAgo’, ‘yesterday’, ‘ga:sessions,ga:…’, Array, ‘qr3_2529266383’)
    #6 /wp-content/plugins/google-analytics-dashboard-for-wp/tools/gapi.php(754): GADWP_GAPI_Controller->get_bottomstats(‘110848844′, ’30daysAgo’, ‘yesterday’, ”)
    #7 /wp-content/plugins/google-analytics-dashboard-for-wp/admin/ajax-actions.php(145): GADWP_GAPI_Controller->get(‘110848844’, ‘bottomstats’, ’30daysAgo’, ‘yesterday’)
    #8 [internal function]: GADWP_Backend_Ajax->ajax_widget_reports(”)
    #9 /wp-includes/plugin.php(503): call_user_func_array(Array, Array)
    #10 /wp-admin/admin-ajax.php(89): do_action(‘wp_ajax_gadash_…’)
    #11 {main}

    https://wordpress.org/plugins/google-analytics-dashboard-for-wp/

Viewing 11 replies - 1 through 11 (of 11 total)
Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Error 400 after some time period’ is closed to new replies.