• Hola,

    Hemos migrado la web de servidor (wpengine) y en este nuevo nos está dando problemas, hemos empezado con un error 403 pero añadiendo los rangos de IP de Redsys y el user agent de java hemos conseguido un error 301.

    Con el error 301 hemos hecho lo siguiente:
    – En el plugin habilitar compatibilidad SNI ya que es let’s encrypt
    – En el servidor añadido la excepción en el SSL para https://konsebeauty.com/^((?!wc-api=WC_Gateway_(.*)redsys).)*$
    – Hemos bajado de PHP 7.4 a PHP 7.3 para poder usar el htaccess y añadido el código de tu web:
    # REDIRECCION CERTIFICADO SSL REDSYS POR JOSE CONTI V.2.0
    RewriteEngine on
    RewriteCond %{QUERY_STRING} !^wc-api=WC_Gateway_(.*)redsys
    RewriteCond %{HTTPS} !=on [NC]
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    # FIN REDIRECCION CERTIFICADO SSL REDSYS POR JOSE CONTI V.2.0

    Pero a pesar de todo esto sigue dando error 301. ¿Alguna idea de por dónde seguir?

    No tenemos ningún plugin tipo iThemes security, sucuri…

    Saludos,
    Ester

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Jose Conti

    (@jconti)

    Hola,

    Utilizais Lets Encrypt y desde hace un tiempo ya no hace falta activar la compatibildiad con SNI.

    Descativad la compatibildiad con SNI, y eliminad el código del htaccess, no hace falta, y podeis utilizar PHP 7.4 sin problemas.

    Unavez hecho, probar de nuevo a ver.

Viewing 1 replies (of 1 total)
  • The topic ‘Error 301’ is closed to new replies.