• Resolved heathotsauce


    I am running WooCommerce 2.0.20 with the theme WooStore.
    I tried installing MailPoet WooCommerce Add-on and it gave me the following error when I go to the WooCommerce Settings>Mailpoet:

    Fatal error: Class ‘WYSIJA’ not found in /home/content/92/10651592/html/wp-content/plugins/mailpoet-woocommerce-add-on/mailpoet-woocommerce-addon.php on line 176

    I tried installing it both by downloading it onto my computer and uploading the zip file, and also within the plug-in search in wordpress.

    Any idea how to fix this issue?

    Thank you!


Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Sebastien Dumont


    Please can you provide your WooCommerce System Report file so that I can take a look and I will get back to you.

    Located here: wp-admin/admin.php?page=woocommerce_status

    Thank you for your cooperation.

    Here is my WooCommerce System Report:

    ### Environment ###

    Home URL: http://heathotsauceonline.com

    Site URL: http://heathotsauceonline.com

    WC Version: 2.0.20

    WC Database Version: 2.0.20

    WP Version: WP 3.8

    Web Server Info: Apache

    PHP Version: 5.2.17

    MySQL Version: 5.0.96-log

    WP Memory Limit: 64 MB

    WP Debug Mode: No

    WP Max Upload Size: 32 MB

    PHP Post Max Size: 33 MB

    PHP Time Limit: 0

    WC Logging: Log directory is writable.

    Default Timezone: Default timezone is UTC

    fsockopen/cURL: Your server has fsockopen and cURL enabled.

    SOAP Client: Your server has the SOAP Client class enabled.

    WP Remote Post: wp_remote_post() was successful – PayPal IPN is working.

    ### Plugins ###

    Installed Plugins: BackUpWordPress by Human Made Limited version 2.3.3, Easy Random Quotes by Kailey Lampert version 1.7, Easy Table by Takien version 1.4, Facebook Pixel Conversions for WordPress by Vincent Astolfi version 0.0.2, Google Analytics Dashboard for WP by Alin Marcu version 4.2.4, Jetpack by WordPress.com by Automattic version 2.7, jQuery Updater by Ramoonus version 2.0.3, MailPoet WooCommerce Add-on by Sebs Studio version 1.0.1, Quick Page/Post Redirect Plugin by Don Fischer version 5.0.3, Welcome to WordPress by Starfield Technologies version 1.0, Woo Radio Buttons Extension by Cyber Infrastructure : Dev – Ankit Mehta version 1.0, WooCommerce Print Invoices & Delivery Notes by Steve Clark, Triggvy Gunderson, David Decker version 2.0.2, WooCommerce USPS Shipping by WooThemes version 3.5.1, WooCommerce by WooThemes version 2.0.20, WooThemes Helper by WooThemes version 1.2.2

    ### Settings ###

    Force SSL: No

    ### WC Pages ###

    Shop Base: #5 – /shop/

    Cart: #6 – /cart/

    Checkout: #7 – /checkout/

    Pay: #14 – /checkout/pay/

    Thanks: #15 – /checkout/order-received/

    My Account: #8 – /my-account/

    Edit Address: #10 – /my-account/edit-address/

    View Order: #11 – /my-account/view-order/

    Change Password: #12 – /my-account/change-password/

    Lost Password: #9 – /my-account/lost-password/

    ### WC Taxonomies ###

    Order Statuses: cancelled (cancelled), completed (completed), failed (failed), on-hold (on-hold), pending (pending), processing (processing), refunded (refunded)

    Product Types: external (external), grouped (grouped), simple (simple), variable (variable)

    ### Theme ###

    Theme Name: WooStore

    Theme Version: 1.7.2 – 1.7.7 is available

    Author URL: http://www.woothemes.com

    ### Templates ###

    Template Overrides: No core overrides present in theme.

    Plugin Author Sebastien Dumont


    You do not have the MailPoet plugin installed from what I can see in this report.

    This add-on requires that you have MailPoet installed for it to connect with each other.

    Install this and the problem will be gone.


    Great, thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error’ is closed to new replies.