WordPress.org

Forums

Loco Translate
[resolved] error (5 posts)

  1. bairdy
    Member
    Posted 1 year ago #

    I am getting this error:
    Error: Failed to open process to /usr/bin/msgfmt -o - -
    OK: PO file saved - nl_NL.po

    Does somebody know what is wrong?

    http://wordpress.org/plugins/loco-translate/

  2. timwhitlock
    Member
    Plugin Author

    Posted 1 year ago #

    It probably means that your msgfmt program is not at /usr/bin/msgfmt.

    Hit the settings tab to set the correct path, or if you don't have Gettext installed, blank out the field.

  3. bairdy
    Member
    Posted 1 year ago #

    Hi do you know how I can find out where the program is installed???

  4. timwhitlock
    Member
    Plugin Author

    Posted 1 year ago #

    Trying typing which msgfmt from the command line.

    If you get nothing, you'll have to do a search for it. If nothing shows up you might have to install Gettext.

    You could also try just entering it into the field as msgfmt with no path. That'll work if the program is installed under one of the web server user's search paths.

  5. timwhitlock
    Member
    Plugin Author

    Posted 1 year ago #

    In case you're still having problems with msgfmt and MO file compilation -

    The current development version (1.3.2) now includes a native MO compiler that does not have a Gettext msgfmt dependency.

    http://wordpress.org/plugins/loco-translate/developers/

    The built-in compiler is the default unless you've already set a msgfmt path. Visit the Settings tab to change which compiler is used.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Loco Translate
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.