Support » Plugin: NextScripts: Social Networks Auto-Poster » Error #1500 – the url you supplied is invalid

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Contributor okapy

    (@okapy)

    It turned out, it’s a Facebook internal problem.

    It’s an old issue https://developers.facebook.com/bugs/476666205677592 that was fixed by Facebook earlier, but reintroduced several days ago.

    We can’t do anything about that, we can only wait for Facebook to fix it.

    99% of my posts are getting this error lately.

    until few days ago I use to receive this error randomly, but now I have this error on every post,.. 100%.. so… any help? I use wordbooker

    Plugin Author NextScripts

    (@nextscripts)

    This error comes from Facebook itself. There is nothing we can do, only wait till Facebook fix it.

    Plugin Author NextScripts

    (@nextscripts)

    Some users who are trying to dig dipper in this issue report that sometimes playing with og: tags help. You can try to add/remove/change your og: tags and see if it helps.

    I have the same issue with the invalid urls…

    Plugin Author NextScripts

    (@nextscripts)

    jurajpuchky Why you keep publishing unrelated code from different plugin?

    This is my fix for facebook-page-publish plugin v1 also can be used as tutor or sample as what is need to be done to fix common issue as was mentioned in this discusion, because it is fix for same error which was discovered in facebook-page-publish same as in other plugins.

    [ERROR] (#1500) The url you supplied is invalid )

    Plugin Author NextScripts

    (@nextscripts)

    How is posting of 67Kb of unrelated code could help? What part of that code solves the mentioned above problem?

    I just went from all changes from released 0.3.9 to the file above, I don’t see anything helpful.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @jurajpuchky? If you have a contribution to those plugins that actually involves those plugins then please feel free to contribute to those plugins in those sub-forums.

    If you are using those plugin forums to socialize your own plugin then please just stop doing that right now. Really.

    Replying to these threads with your own independent solution that has nothing to do with the plugin being discussed? That’s spamming and is not allowed here.

    You can submit your plugin using this guideline.

    http://wordpress.org/plugins/about/guidelines/

    If your plugin is accepted then you can have your own support sub-forum for that plugin.

    It seems to publish to a Facebook page fine but not to my personal wall. So I have been able to share it from a page manually. A pain but a work around until it is fixed.

    Is there any indication from Facebook that this is being addressed?

    Plugin Author NextScripts

    (@nextscripts)

    There are several discussions on Facebook regarding this issue. The reason is that Facebook is failing to get response from your server in time and process/cache it. Making correct OG: tags helps it to do it better. Upgrading to the faster server or hosting provider that working faster from Facebook’s location could help also.

    Facebook is working on improving the access time, but results so far are not so good.

    Plugin Author NextScripts

    (@nextscripts)

    Another possible cause and solution from one of our users:

    I was able to solve the problem.

    The “og:tags” were the reason. The “evil” plugin was “2-click-buttons” which added duplicates of the “og:”-tags to the site.

    Because of the german data privacy act this is the only legal way to display Facebook “like” and “share”-buttons here. So this plugin is *very* popular in germany and maybe this information might help others.

    Solution:
    Click onto “Disable Open-Graph-Tags” under the “Other Settings” Menu of the 2-Click-Plugin-Buttons-Plugin

    I am also getting this error all the time and I tried several things but one seemed to partially work.

    I made a change in my Wordbooker settings and saved the blog level options. I was then able to publish 2 posts to FB and then the 3rd and 4th gave me the error again.

    I undid the change to my Wordbooker settings and saved the blog level options again. I was again able to publish 2 posts successfully to FB and then started getting the error again on the 3rd attempt.

    I then went back to Wordbooker and made NO changes but just pressed the Save Blog Level Options button again. I was again able to publish 2 posts successfully.

    It seems that if this error was purely Facebook’s issue, I would not be able to publish anything. And it is very strange to me that by just going through the process of saving the blog level options in Wordbooker I am able to publish 2 posts successfully each time.

    I ran out of posts to publish for today, but I hope these findings help identify and fix this problem.

    Trishah

    (@trishahdee)

    [ERROR] (#1500) The url you supplied is invalid

    I’m getting this error also. And I was able to get one post that was large image and text only to publish, but none of the others.

    The test post gets published every time but not any of my regular posts.

    Also, is there a way to “re-publish” a post so I don’t have to come up with a new post in order to test if it’s working? I tried turning a post to draft then publishing again but that doesn’t work.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Error #1500 – the url you supplied is invalid’ is closed to new replies.