Support » Plugin: Disable Gutenberg » Error?

  • Resolved shirtguy72

    (@shirtguy72)


    Hello Jeff, was just troubleshooting another plugin and found the following in php_errorlog ….

    [23-Oct-2019 19:58:10 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘disable_gutenberg_wp_enqueue_scripts’ not found or invalid function name in /home/********/public_html/wp-includes/class-wp-hook.php on line 286

    Front and backend working fine, not sure what this error message is, just wanted to give a heads up.

    If you need more info. just ask

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Hi @shirtguy72, thanks for reporting. This is the first hearing of this error, do you know how to trigger it? For example, is there a specific page or URL that needs visited in order to cause the error?

    I haven’t a clue Jeff, just messed around but couldn’t reproduce.
    I did though update Rank Math SEO a few minutes before the error took place, here is the changelog …

    https://wordpress.org/plugins/seo-by-rank-math/#developers

    Plugin Author Jeff Starr

    (@specialk)

    Thanks for that, @shirtguy72. I will investigate this soon and resolve any errors that I can find. Let me know if you discover any further clues and/or related infos, etc.

    Thanks Jeff, I sure will. Not sure if this is related but shortly after DGutenberg error the following happened with WP Optimize, error occurred with their image compression tool. The following support thread was stared…

    Just updated, compressed four images that were in a draft post and got the following in php_errorlog …

    [23-Oct-2019 21:38:21 UTC] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ”
    AND last_locked_at <= ‘1571866641” at line 3 for query
    UPDATE ***_***tm_tasks
    SET last_locked_at = 1571866701
    WHERE id = 4’
    AND last_locked_at <= ‘1571866641’
    made by do_action(‘wp_ajax_updraft_smush_ajax’), WP_Hook->do_action, WP_Hook->apply_filters, Updraft_Smush_Manager->updraft_smush_ajax, Updraft_Smush_Manager_Commands->process_pending_images, Updraft_Smush_Manager_Commands->process_bulk_smush, Updraft_Smush_Manager->process_bulk_smush, Updraft_Task_Manager_1_2->process_queue, Updraft_Task_Manager_1_2->process_task, Updraft_Task_1_1->attempt, Updraft_Task_1_1->lock

    Plugin Author Jeff Starr

    (@specialk)

    Thanks for reporting @shirtguy72, every bit helps!

    Plugin Author Jeff Starr

    (@specialk)

    Hey @shirtguy72, just to follow up with this, the reported issue is resolved in the next version of DG. Expected available next week or so. Thanks again for reporting.

    Awesome! Just to add: I now practice using WPO’s image optimizer before I publish my post and I have done away with using the same dev’s MetaSlider as a related post deal … Now placing my own custom HTML widgets under content to achieve better click-through. Since that time, no errors of any kind, including a “recoverable fatal error” that kept occurring naming my theme. Kudos and more thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.