Support » Plugin: SV100 Companion » Error

  • Resolved Emaitube

    (@emaitube)


    Stack trace:
    #0 /home/XXXXXX/public_html/wp-content/plugins/sv100-companion/lib/core_plugin/core/core.php(69): sv_core\core->set_core_update_warning()
    #1 /home/XXXXXX/public_html/wp-content/plugins/sv100-companion/lib/core_plugin/core/abstract.php(252): sv_core\core->setup_core(‘/home/XXXXXX/…’, ‘sv100’)
    #2 /home/XXXXXX/public_html/wp-content/themes/sv100/lib/core_theme/core_theme.php(36): sv_core\sv_abstract->setup(‘sv100’, ‘/home/alexhpbr/…’)
    #3 /home/XXXXXX/public_html/wp-content/themes/sv100/lib/core_theme/core_theme.php(394): sv100\init->init()
    #4 /home/XXXXXX/public_html/wp-content/themes/sv100/functions.php(7): require_once(‘/home/XXXXXX/…’)
    #5 /home/al in /home/XXXXXX/public_html/wp-content/plugins/sv100-companion/lib/core_plugin/core/core.php on line 93

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author straightvisions GmbH

    (@matthias-reuter)

    Hi Alex,

    thank you for the info. Do you have the specific error message? You’ve posted the stack-trace only, but the error message would help us to identify the issue.

    Kind regards,

    Matthias

    Only generated this error in the server error log and the site went down. But, I managed to come back here, updating the theme. I went to your site and downloaded the latest version and updated, then came back.

    The site went back to work after being updated, but the functions of the theme, within the administrative area, were all messed up. That is, it is not possible to move.

    [05-Sep-2019 17:39:56 UTC] PHP Fatal error: Uncaught ArgumentCountError: Too few arguments to function sv_core\core::set_core_update_warning(), 0 passed in /home/XXXXX/public_html/wp-content/plugins/sv100-companion/lib/core_plugin/core/core.php on line 69 and exactly 1 expected in /home/XXXXX/public_html/wp-content/plugins/sv100-companion/lib/core_plugin/core/core.php:93

    Plugin Author straightvisions GmbH

    (@matthias-reuter)

    Hi Alex,

    I’ve just uploaded latest beta on (directdownload) https://straightvisions.com/go/sv100/

    Can you update theme with this package and try again?

    If that does not help, please send an email to matthias-bathke@straightvisions.com for individual support for your installation – I’d be glad to get it solved for you.

    Kind regards,

    Matthias

    Plugin Author straightvisions GmbH

    (@matthias-reuter)

    Thank you for providing the error message, I’ve addressed the issue and it should be fixed now. Please redownload / update Theme and Companion Plugin again to get it fixed.

    Thank you for your feedback and if you need any further assistance or support, please never hesitate to ask 🙂

    Would be great if you could confirm the fix or tell me if there is still an issue.

    The site is back to normal. However, the theme options do not appear, it seems to me to be a module or module error. Well, this is the new mistake it generates.

    [05-Sep-2019 17:57:33 UTC] PHP Fatal error: Uncaught Exception: Class could not be loaded (tried to load class-file settings/modules/.php) in /home/XXXXX/public_html/wp-content/plugins/sv100-companion/lib/core_plugin/core/settings/settings.php:63

    Plugin Author straightvisions GmbH

    (@matthias-reuter)

    Hi Alex,

    I’d love to take a deeper look into your installation to avoid that you need to invest more time in debugging our theme. The Class error quoted above shouldn’t appear and maybe there are still some outdated files somewhere.

    Please provide me FTP and WP-Admin access via email to matthias-bathke@straightvisions.com and I’ll take care and fix these issues tomorrow. I recommend giving me access to a staging/dev-copy of your site to not bother your users while I fix the issues on your site.

    I am sorry that you have these errors while updating, but your feedback helps a lot to get our theme more polished until release and to avoid those issues in future, so big thanks for your effort here!

    Kind regards,

    Matthias

    Ok, I already sent it to you. Thank you!

    Plugin Author straightvisions GmbH

    (@matthias-reuter)

    Hi Alex,

    big thanks for your patience. I’ve updated and patched your installation with most recent theme version and it looks good now. Hope everything works as expected now, but if you have any other issues, we are here to support 🙂 If you can confirm that the issue has been fixed, a quick note would be appreciated.

    Kind regards,

    Matthias

    Now it’s perfect, thank you very much. Your theme is getting better every day. Congratulations!

    Plugin Author straightvisions GmbH

    (@matthias-reuter)

    Big thanks, you are welcome 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Error’ is closed to new replies.