WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] erroneous /comment-page-1 in comment url generated after commenting

[Resolved] erroneous /comment-page-1 in comment url generated after commenting

Viewing 8 replies - 1 through 8 (of 8 total)
  • As of WordPress 2.7, WordPress supports Comment Paging, So the /comment-page-1/ refers to the first page worth of comments.

    However, It is a bit anoying it gets added even when the image would’ve been amongst the comments on the first page.

    If you’re getting a 404 page, you might need to refresh your permalinks, Open the Permalink settings page, and click update, then see what happens

    maha-online
    Member

    @maha-online

    Thanks for your comment. I updated .htaccess and commenting works fine!

    what did you add to .htaccess to resolve this?
    Thanks.

    dkusleika
    Participant

    @dkusleika

    I disabled comments pagination under Settings – Discussion and that fixed it for me. So if you don’t care if your comments are on pages, then that’s an easy fix.

    I was banging my head for weeks over this one… Thanks to dkusleika for mentioning that settings’ location. Disabling pagination under Settings -> Discussion worked like a charm for me.

    Cheers!

    @maha-online to echo @jdybka‘s comment, what did you add to .htaccess to resolve this? i would like to take advantage of the new pagination features and not just turn it off. Can someone please explain?! Thanks.

    trentor
    Member

    @trentor

    I agree. I would like to actually use the pagination feature. What needs altered in .htaccess?

    Douglas Karr
    Participant

    @douglaskarr

    I was able to add a rewrite rule to my .htaccess file to strip the comment-page-1/ from the URL:
    RewriteRule ^(.*)/comment-page-1/ $1/ [R=301,L]

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] erroneous /comment-page-1 in comment url generated after commenting’ is closed to new replies.