Support » Plugin: Ajax Upload for Gravity Forms » Error upload version 2.5.1

  • Hello,

    I have an error with the latest version of the program.

    Non problem with version 2.4.9

    Thanks
    Regards

    • This topic was modified 2 years, 10 months ago by grosducat.
Viewing 11 replies - 1 through 11 (of 11 total)
  • Version 2.4.5 not 2.4.9

    • This reply was modified 2 years, 10 months ago by grosducat.
    Plugin Author ovann86

    (@ovann86)

    Hey,

    Could you do me a favour and open the page with the form with ?gform_debug at the end and report back the error message.

    e.g.

    https://demo.itsupportguides.com/ajax-upload-for-gravity-forms/multi-page-form/?gform_debug

    This will hopefully give me the specific line that is causing the issue.

    Also – which browser are you seeing this in? (e.g. internet explorer)

    Hello,

    The option “Display script errors to users ” is already activated.
    I do not have more information.
    Error in chrome and firefox.

    In firefox:

    Am I the only one who has that problem?

    Thanks
    Regards

    Plugin Author ovann86

    (@ovann86)

    Hey,

    It looks like you’re the only one having issues – I can’t reproduce the issues in any of my websites and no one else has reported issues.

    I will try a slight change that might fix it, but it’s hard to know without knowing the exact line that is causing the issue.

    If you still have the problem I need you to open the form with ?gform_debug at the end and report back the error message.

    e.g.

    https://demo.itsupportguides.com/ajax-upload-for-gravity-forms/multi-page-form/?gform_debug

    This will hopefully give me the specific line that is causing the issue.

    Good morning Ovann,

    Still not working.

    I do not understand what I have to do.You mean the option “Display script errors to users” in “Debug settings” of “Ajax Upload” in my web ?
    In this case it still indicates line 1.

    Thank you and good sunday

    Hello,

    I’ve tried the latest version (2.7.2) and it does not work either.
    But this time I get line 190 in error in the file “itsg_gf_ajaxupload_js.js”.

    I have 2 “ajax upload” in 1 form, this causes the error.
    Not problem with 1 “ajax upload”.
    No problem with the version 2.4.5.

    I put a link in case you want to see the form:
    https://fineartfoto.es/papeles-mate/moab-entrada-rag-natural-290/

    Thanks
    Regards

    Plugin Author ovann86

    (@ovann86)

    Hey,

    In the latest version (which I would say you’ve got now) I made a slight change to help find this specific line that’s causing the issue.

    Line 190

    var form_id = jQuery( this ).parents( 'form' ).attr( 'id' ).split( '_' ).pop().trim();

    So here we’re trying to get the form id, which seems to be difficult in older versions of Gravity Forms. But from what I can see you have a current (enough) version. Version 2.1.2.10

    Looking at your form, I don’t see the ID attribute

    <form class="cart" method="post" enctype="multipart/form-data">

    How are you loading the form in the page? Are you using a shortcode (e.g. [gravityform] or function call?

    https://www.gravityhelp.com/documentation/article/embedding-a-form/

    Good Morning ovann86,

    I use the version (Ajax Upload for Gravity Forms) 2.4.5. Later versions do not work.
    When I use version 2.7.2 i have error line 190, i do not have more details, I’m sorry.

    Yes, i use gravity forms version 2.1.2.10 and shortcode ([product_page id=”1195″]) for product in woocommerce.

    Thanks
    Regards

    Hello again,

    The code “<form class=”cart” method=”post” enctype=”multipart/form-data”>” is present in my HTML, I’ve found it.

    Regards

    Plugin Author ovann86

    (@ovann86)

    OK, so the problem you are having is because your <form> is missing the required id, which is there by default.

    It should look something like

    <form id="gform_3" method="post" enctype="multipart/form-data" action="..." _lpchecked="1">

    Instead you’re missing the id attribute and you have a class

    <form class=”cart” method=”post” enctype=”multipart/form-data”>

    Which leads me to believe somewhere you’re using the gform_form_tag filter

    https://www.gravityhelp.com/documentation/article/gform_form_tag/

    What you need to do is work out where or how the id is being removed and make sure it doesnt.

    The gform_form_tag can be a bit tricky to do advanced changes with, so if you get stuck with this the Gravity Forms support people can help out. But all you need to do is make sure you’re not removing the built in id attribute.

    • This reply was modified 2 years, 10 months ago by ovann86.

    What I find strange is that version 2.4.5 works, later versions do not.

    How do you make a donation in https://www.itsupportguides.com/ ?

    Regards

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Error upload version 2.5.1’ is closed to new replies.