Support » Plugin: WooCommerce Correios - Cálculo de Frete na Página do Produto » Erro na hora de pegar o paramentro “Valor” – JS

  • Resolved xlucas6x

    (@xlucas6x)


    Quando insiro o cep ele me começa a processar e o loading fica eternamente, quando aperto o F12 pra inspecionar ele me retona o seguinte erro:

    Uncaught TypeError: Cannot read property ‘Valor’ of undefined
    at Object.success (woocommerce-correios-calculo-de-frete-na-pagina-do-produto-public.js?ver=1522678741:76)
    at i (jquery.js?ver=1.12.4:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
    at y (jquery.js?ver=1.12.4:4)
    at XMLHttpRequest.c (jquery.js?ver=1.12.4:4)

    Obrigado, espero que consiga me ajudar.

Viewing 10 replies - 1 through 10 (of 10 total)
  • @xlucas6x, boa tarde

    passei por esse problema. Resolvi atualizando o woocommerce, pois na versão mais recente é possível cadastrar o CEP de origem no painel de administração.

    Att,

    @niteroiwebsites acabei de verificar e não tem nenhuma atualização pendente e meu cep esta declarado no painel de administração, tem mais alguma dica ?

    Você usa algum plugin de cache e minify?
    O módulo dos correios está atualizado?

    @niteroiwebsites

    O módulo dos correios está atualizado?
    Sim, verifiquei no painel do wp e não tem nada para ser atualizado, tem alguma outra forma ?

    Você usa algum plugin de cache e minify?
    Não uso nenhum dos 2

    A final, onde insiro o cep é direto no plugin do wordpress certo ?

    Segue minha página com erro: https://www.inventtostudio.com.br/wp/produto/tshirt/

    niteroiwebsites

    (@niteroiwebsites)

    Para configurar o CEP vai vai em Gerenciar Loja -> Connfiguração

    Veja o print: http://prntscr.com/j0aqrm

    @niteroiwebsites Continuo com o mesmo problema, desinstalei e instalei novamente, coloquei o CEP no woocomerce direto, porem continuo com o problema…

    Se conseguir alguém conseguir me salvar nessa eu agradeço!!

    Obrigado

    att

    anibalsa

    (@anibalsa)

    Lucas,
    Dá uma olhada no meu tópico “Sem retorno”.
    Creio que você está falando do mesmo erro que encontrei.
    Nesse tópico apontei onde fiz a correção no plugin.

    Abraço

    xlucas6x

    (@xlucas6x)

    @anibalsa

    Bom dia!
    Acabei de verificar, tentei debugar e tudo mais porem ele n encontra nada, o erro esta dando nesta linha

    -> pac.find(‘[data-custo]’).text(result.pac.Valor);

    Especificamente ele não encontra este parametro na hora de escrever no campo: result.pac.Valor

    Alguem pode me ajudar?

    Obrigado

    Att
    Lucas

    Plugin Author lucasbustamante

    (@lucasbustamante)

    Fala aí galera, acabei de lançar a versão 1.5.6 do plugin que resolve esse problema. Se persistir me fala aqui. Abraços!

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.