Support » Plugin: WooCommerce Boleto e PIX PagHiper » Erro após atualizações

  • Resolved cfelipe74

    (@cfelipe74)


    Olá,

    Utilizo o plugin, e após algumas atualizações, o meu painel do wordpress passou a mostrar o seguinte aviso:

    “Warning: count(): Parameter must be an array or an object that implements Countable in /home1/nahya983/blingmix.com.br/wp-content/plugins/woo-boleto-paghiper/includes/paghiper-php-sdk/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 67

    Vejo também que este aviso causou um problema com as atualizações em segundo plano:

    “Um plugin tem impedido atualizações desabilitando wp_version_check().”

    Já desabilitei o plugin, e verifiquei que o problema é mesmo dele, pois os erros somem quando faço isso;
    Existe alguma solução para este problema?

    Agradeço desde já a atenção.

    Felipe

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter cfelipe74

    (@cfelipe74)

    Em tempo, o plugin está atualizado na última versão disponível, que é a 2.0.4.

    Plugin Author Henrique Cruz

    (@henriqueccruz)

    Olá @cfelipe74 !
    Na verdade essa mensagem não se trata de um erro.
    Ela é apenas um warning, e não deveria sequer aparecer.
    Como essa mensagem está aparecendo no seu painel, você pode ter a diretriz display_errors ativada no PHP ou a constante WP_DEBUG está definida como true no seu arquivo wp-config.php

    É má prática deixar os warnings/erros visíveis em servidores expostos na internet.
    Basta modificar isso e a mensagem não aparecerá mais. Caso você não saiba como fazê-lo, seu provedor de hospedagem deve conseguir te ajudar com isso com bastante facilidade.

    No mais, o plugin tem funcionado pra você? Ou precisa de ajuda com outra questão?

    Thread Starter cfelipe74

    (@cfelipe74)

    Olá Henrique, tudo bom?

    Realmente, o item “display_errors” no php.ini estava ativado, o que eu não sabia.
    O WP_DEBUG já estava configurado como “false”.

    Desativei a opção no php.ini, e tudo voltou ao normal.
    O plugin é excelente, e me atende muito bem! Parabéns!

    Agradeço o auxílio!

    Abs…

    Olá

    Também tive problema com a notificação.
    Coloquei WP_DEBUG para false no arquivo wp-config.php e não aparece mais o erro.

    Mas quando habilito novamente para ver algum bug, eu tenho que desabilitar o plugin também, pois não consigo acesso ao painel do WordPress, devido a notificação.

    Estas atualizações do PHP é complicado, aprendemos de uma forma e agora é de outra.

    Segue artigo explicando o “Countable” e como resolver.

    https://www.gigasystems.com.br/artigo/106/error-php-7-2-count-parameter-must-be-an-array-or-an-object-that-implements-countable

    Valew!

    Plugin Author Henrique Cruz

    (@henriqueccruz)

    Ja temos uma atualização em processo de homologação, que corrige este problema.
    Lançaremos nos próximos dois dias.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Erro após atualizações’ is closed to new replies.